Internal host lookup fails

Discussion in 'General' started by curiogeo, Mar 22, 2007.

  1. curiogeo

    curiogeo New Member

    I used the MyDNS with MyDNSConfig Control Panel and DNSMasq on Ubuntu 6.10 tutorial to install Mydns and dnsmasq.

    dnsmasq is listening on and external requests are being forwarded there but my internal requests are not getting any where.

    If I ping the nameserver from a host on the LAN it is failing but if a ping externally the resolver is passing on the address.

    I am not sure where I am going wrong.

    Lan requests are directed to the right IP addss in DHCP settings so I am at a loss.

    Could anyone help me to wade through this mess?
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in your /etc/resolv.conf?
  3. curiogeo

    curiogeo New Member

    Search home.internal
    nameserver (ip of mydns)

    so far the dnsmasq seems to be querying the root servers directly for dns queries. As far as I can tell the local mysql mydns table does not recognize the home.internal domain and is passing the query directly to the resolver.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to set in resolv.conf only this one line:


    normally mydns should pass every dns query it is not able to answer to the dnsmasq server itself.
  5. curiogeo

    curiogeo New Member

    I made the change you suggested and restarted networking

    Here are the results of an internal dig. Looking to the root server.

    ; <<>> DiG 9.3.2 <<>> home.internal
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 40399
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;home.internal. IN A

    . 10757 IN SOA A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2007032300 1800 900 604800 86400

    ;; Query time: 33 msec
    ;; SERVER:
    ;; WHEN: Fri Mar 23 22:38:40 2007
    ;; MSG SIZE rcvd: 109
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You are sure that you have a SOA created for home.internal in mydns that works from all other IP addresses except from the local IP?

Share This Page