Integrating Amavisd-new Into Postfix For Spam- And Virus-Scanning

Discussion in 'HOWTO-Related Questions' started by tommytomato, Jul 7, 2007.

  1. tommytomato

    tommytomato New Member

    Hi all

    I have another box up and install with the following done

    http://www.howtoforge.com/perfect_setup_ubuntu_6.06

    my system is ubuntu 6.06.1

    when running the commands from http://www.howtoforge.com/amavisd_postfix_debian_ubuntu_p2

    i get the following message, is there another post of fix for it, I cant seem to find it.

    Code:
    ~# apt-get install -f  amavisd-new spamassassin clamav clamav-daemon zoo unzip unarj bzip2 unzoo libnet-ph-perl libnet-snpp-perl libnet-telnet-perl nomarch lzop
    Reading package lists... Done
    Building dependency tree... Done
    amavisd-new is already the newest version.
    spamassassin is already the newest version.
    zoo is already the newest version.
    unzip is already the newest version.
    Package unarj is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package unarj has no installation candidate
    
    
    TT
     
  2. tommytomato

    tommytomato New Member

    I took out the following packages to try install what was left

    Code:
    apt-get install clamav clamav-daemon bzip2 unzoo libnet-ph-perl libnet-snpp-perl libnet-telnet-perl nomarch lzop
    to try install what was left

    this is the message i get

    Code:
    # apt-get install clamav clamav-daemon bzip2 unzoo libnet-ph-perl libnet-snpp-perl libnet-telnet-perl nomarch lzop
    Reading package lists... Done
    Building dependency tree... Done
    bzip2 is already the newest version.
    unzoo is already the newest version.
    libnet-ph-perl is already the newest version.
    libnet-snpp-perl is already the newest version.
    libnet-telnet-perl is already the newest version.
    nomarch is already the newest version.
    lzop is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      clamav: Depends: libclamav2 (>= 0.90.3) but it is not going to be installed
      clamav-daemon: Depends: libclamav2 (>= 0.90.3) but it is not going to be installed
    E: Broken packages
    
    I'm not real sure on what going on

    TT
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Please add libclamav2 to the apt-get install command.
     

Share This Page