Intall faults - no login anymore

Discussion in 'Installation/Configuration' started by tom, Jan 17, 2007.

  1. tom

    tom Member

    If upgraded to 2.2.9 and got the following install report and now an can't login anymore in ISPConfig. I've not changed any password. But what can I do to login again?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that your server ran out of disk space during the update.

    Please try to get some more fee space on your harddisk.

    Please make also sure that you delete all files and directories in /home/admispconfig/ispconfig/temp/ except of the webmail directory.

    Then run:

    mkdir /root/ispconfig

    and try the update again.
     
  3. tom

    tom Member

    I've done as you said but now see the updateresult. I've 715MB free space. I think that should be enough.
    ISPConfig is not running. Now I can't connect to the loginpage of ISPConfig
     
    Last edited: Jan 18, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    Please delete /root/ispconfig, then run
    Code:
    mkdir /root/ispconfig
    and download and unpack ISPConfig again. Then try a new update.
     
  5. tom

    tom Member

    Ok, I've deleted /root/ispconfig and ISPConfig ist installed, I could set an new password and can login but even an new ISPConfig-database which the same name was created. Now I can't manage the websites etc. beause ISPConfig is showing me not even one website, account or anything else but the domains are still connected to the server an even everything is there only ISPConfig is not showing it. I don't know what to do not to lose everything by making any change whith ISPConfig now.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Falko told you to delete /root/ispconfig and not the complete ISPConfig. As you deleted the complete ISPConfig, you lost all data in the database. Doy ou have a backup of the ISPConfig database?
     
  7. tom

    tom Member

    I did what Falko told
    and only that I did. No, I don't have a backup. I've killed it before to get more space...I know a big mistake not to have one. But during the installprocess the ISPConfig installer told me that there is an other database with the same name. I don't understand what I should have done wrong. And what I can do now. I think I can create new website with ISPConfig and use the still available stuff in the directories. How could I do it most best?
    ???
     
    Last edited: Jan 19, 2007
  8. falko

    falko Super Moderator ISPConfig Developer

    This means that the ISPConfig installer was in install mode, not in upgrade mode. This happens only if both /root/ispconfig and /home/admispconfig do not exist.
    Did you delete /home/admispconfig?
     
  9. tom

    tom Member

    No.
    And even I've checked my history and found that I only did this
    But I saw that some directorys and files in /home/admispconfig were changed but not all.
     
    Last edited: Jan 20, 2007
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Without a backup of the original database, ISPConfig can not be restored. Please check also your /tmp directory, if there is really no .sql file with the database contents
     
  11. tom

    tom Member

    Nothing ind /tmp - But how could the database go away during the update even though I did not delete /home/admispconfig?
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    You posted in this thraed that you deleted the databse. The database is not in /home/admispconfig, its in /var/lib/mysql
     
  13. tom

    tom Member

    I've not deleted the database from ISPConfig. I've deleted an backup of the database. The database which is located in /var/lib/mysql seems not to be the old one.

    I still don't understand how the old database could be go away during the upgrade process.
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Maybe your hard disk or one of your partitions got full during the upgrade.
    Are there any errors/warnings in ISPConfig's install_log in /var/log/?
     
  15. tom

    tom Member

    No errors or warnings in /var/log/ispconfig_install.log but these strange entries:

     
  16. falko

    falko Super Moderator ISPConfig Developer

    These entries are ok.

    Does your MySQL root password contain special characters?
     

Share This Page