Installing Xen On An Ubuntu Feisty Fawn Server From The Ubuntu Repositories: On 7.10

Discussion in 'HOWTO-Related Questions' started by Kai, Nov 4, 2007.

  1. Kai

    Kai New Member

    Hi all,

    I am trying to make myself a home server sonsisting of multiple Xen VMs for different purposes.
    But before I get to the point I can have some fun configureing the VMs I need to create them first, and thats where I am stuck.

    I installed Ubuntu 7.10 Desktop on my server (since I didnt get the GUI working on the server edition) and is now fiddling with the xen-tools.

    And I thought this howto wouldnt be far off my set up, but its not working :confused:

    I followd the instruction (with some modifications) and the xen-create-image command halts on "Installation method: debootstrap", I can hear some disk activity for some seconds and I see some blinking on the NIC but after maby a minute the keyboard stops working and the mouse poniter gets really sluggish and nothing else works so I have to hard reboot the system.

    Here is my create command:
    xen-create-image --hostname=foo --size=4Gb --swap=256Mb --ide \
    --dhcp --force \
    --dir=/vserver --memory=256Mb --arch=i386 --kernel=/boot/vmlinuz-2.6.22-14-xen \
    --initrd=/boot/initrd.img-2.6.22-14-xen --debootstrap --dist=gutsy \
    --mirror= --passwd

    I might have made one mistake though, I tried to do it myself before I looked up the howto and installed the ubuntu-xen-desktop package instead of the server one in the guide. But from what I can tell its the same thing with added GUI stuff.

    Another thing I am not sure of is that the server is directly connected to my cable modem with DHCP since I dont have a router (wich will be the first task I will give this box). And since the host system is also using DHCP with only one address available, I am not sure how Xen responds to this. I tried to set the main interface to before I ran the create command but there was no progress.

    Any clues?
  2. falko

    falko Super Moderator ISPConfig Developer

    I've just written a guide for Ubuntu 7.10:
    but it isn't much different that the 7.04 guide, so that should work, too.
    Did you take a look at your logs? Maybe you don't have enough RAM or hard disk space?

    If your modem has a DHCP server, then it is already a router.
  3. Kai

    Kai New Member

    Thanks for the reply,

    For some reason I didnt recive a mail stating your feedback until 24.12 :confused:

    Found the fault though, it was that I couldnt get a second IP address from the ISP.
    So I snuck out a spare Cisco router from work and used that instead until I get a gateway running on a virtual server.
    Works like a charm now :)


Share This Page