Installing XBMC on Fedora 9 Error

Discussion in 'HOWTO-Related Questions' started by WardYorgy, May 26, 2009.

  1. WardYorgy

    WardYorgy New Member

    I've been trying to install XBMC for the past two hours, and after fixing a bunch of problems, I ran into one I can't figure out. When I type "make" it says:

    /usr/lib/gcc/i386-redhat-linux/4.3.0/../../../../include/c++/4.3.0/bits/basic_string.h:1133: internal compiler error: Segmentation fault
    Please submit a full bug report,
    with preprocessed source if appropriate.
    See <> for instructions.
    The bug is not reproducible, so it is likely a hardware or OS problem.
    make[1]: *** [CMythSession.o] Error 1
    make[1]: Leaving directory `/root/XBMC/linuxport/XBMC/xbmc/FileSystem'
    make: *** [xbmc/FileSystem/filesystem.a] Error 2
    Last edited: May 27, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    *Could* be a hardware problem.
  3. WardYorgy

    WardYorgy New Member

    Fedora 10 won't work

    Since it didn't work on Fedora 9, I ended up reformatting my computer by upgrading to Fedora10. Now I get this error when I run ./configure

    Done, type 'make install' to build and install
    cat /home/Ward/different folder/linuxport/XBMC/xbmc/cores/dvdplayer/Codecs/libdvd/libdvdread/misc/ >> obj/dvdread-config
    cat: /home/Ward/different: No such file or directory
    cat: folder/linuxport/XBMC/xbmc/cores/dvdplayer/Codecs/libdvd/libdvdread/misc/ No such file or directory
    make: *** [obj/dvdread-config] Error 1
    cp: target `folder/linuxport/XBMC/xbmc/cores/dvdplayer/Codecs/libdvd/libdvdread/../includes/dvdread' is not a directory
    ~/different folder/linuxport/XBMC
    configure: error: Submodule xbmc/cores/dvdplayer/Codecs/libdvd/libdvdread failed to configure

    Please tell me what to do.

Share This Page