Installing Webmin on Ubuntu Linux (Server edition)

Discussion in 'Installation/Configuration' started by U2XS, Apr 1, 2007.

  1. U2XS

    U2XS New Member

    I'm following This Tutorial and I got to the early step of installing webadmin. The version is newer than the one in the tutorial and it tells me that it will not install because it does not have the dependencies.

    I have tried the following commands with some success
    Finally I got as far as this step. But here is where I am stuck. Can anyone help me download/locate/install these dependencies?
     
  2. iverson0881

    iverson0881 New Member

    please use the command:

    apt-get install libnet-ssleay-perl libauthen-pam-perl libio-pty-perl libmd5-perl

    then run:

    dpkg -i webmin_1.330_all.deb

    It should work then.
     
  3. xerophyte

    xerophyte ISPConfig Developer ISPConfig Developer

    But it recommended to install the webmin from the source tarball, because the deb configure differently.
     
  4. U2XS

    U2XS New Member

    Thanks for the response. I tried the code and wound up with this.

    It seems that we've found the problem. Does anyone know how to install libauthen-pam-perl seperately - not directly from the server?? Thanks
     
  5. iverson0881

    iverson0881 New Member

  6. falko

    falko Super Moderator ISPConfig Developer

    Yes, please make sure that the universe repository is enabled in /etc/apt/sources.list.
     
  7. U2XS

    U2XS New Member

    I'm pretty sure this is it. I just looked at the file in the directory you mentioned and it states.

    How do I enable the Universe repository?
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Please post your full /etc/apt/sources.list.
     
  9. U2XS

    U2XS New Member

  10. falko

    falko Super Moderator ISPConfig Developer

    Please uncomment these two lines:
    Code:
    # deb http://us.archive.ubuntu.com/ubuntu/ edgy universe
    # deb-src http://us.archive.ubuntu.com/ubuntu/ edgy universe
    so that they read
    Code:
    deb http://us.archive.ubuntu.com/ubuntu/ edgy universe
    deb-src http://us.archive.ubuntu.com/ubuntu/ edgy universe
    Run
    Code:
    apt-get update
    afterwards.
     

Share This Page