Installing problem let's Encrypt.

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Sep 28, 2016.

  1. pawan

    pawan Member HowtoForge Supporter

    Hi Till
    Thanks for the guidance.
    I have done the way, but just enabling the checkbox.
    Now I am getting this error while accessing the website with HTTPS
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is mywebsolutions.co.in your real domain? The letsencrypt cert on that domain is valid, I don't get an error.
     
  3. pawan

    pawan Member HowtoForge Supporter

    yes mywebsolutions.co.in is my real domain. I have created a certificate at sslforfree.com(which uses let's encrypt to sign the certificate) and saved it in mywebsolutions.co.in SSL Tab.
    That's working fine without any issue.
    But while creating certificate from within ISPCONFIG for cbsindia.in and accessing https://cbsindia.in
    I am getting this error.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. pawan

    pawan Member HowtoForge Supporter

    Till,
    It appears that it is solved but only partly.
    After applying the fix above, I have created the certificate for jaigustone.com
    Now that is working fine.
    Then Again I have tried to create the certificate for cbsindia.in and when trying to access https://cbsindia.in it is generating error
     
  6. nokia80

    nokia80 Member

    i have the same problem how i set default settings?
     
  7. nokia80

    nokia80 Member


    i have eneable 1 website to lets encrypt now al the website are offline pleace help no controle panel everything offline
     
  8. pawan

    pawan Member HowtoForge Supporter

    You go to the specific vhost file in /etc/apache2/sites/enabled.
    and manually remove the part
    Code:
    <IfModule mod_ssl.c>
    </IfModule mod_ssl.c>
    and restart apache.
    That is temporary solution.
    I am also waiting for the proper solution.
     
    nokia80 likes this.
  9. pawan

    pawan Member HowtoForge Supporter

    Hi Till,
    This is the apache debug log I am putting here, if that can help to know where is the problem.
    When I am just enabling the checkbox for SSL for cbsindia.in, the vhost file is not getting updated.
    Here is the detail of the error:
    Code:
    29.09.2016-20:08 - DEBUG - Processed datalog_id 19017
    29.09.2016-20:08 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    29.09.2016-20:09 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    29.09.2016-20:09 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    29.09.2016-20:10 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    29.09.2016-20:10 - DEBUG - Found 1 changes, starting update process.
    29.09.2016-20:10 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    29.09.2016-20:10 - DEBUG - Calling function 'update' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    29.09.2016-20:10 - DEBUG - exec: usermod --groups sshusers web27 2>/dev/null
    29.09.2016-20:10 - DEBUG - Creating fastcgi starter script: /var/www/php-fcgi-scripts/web27/.php-fcgi-starter
    29.09.2016-20:10 - DEBUG - Enable SSL for: cbsindia.in
    29.09.2016-20:10 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/cbsindia.in.vhost
    29.09.2016-20:10 - DEBUG - Apache status is: running
    29.09.2016-20:10 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    29.09.2016-20:10 - DEBUG - Restarting httpd: service apache2 restart
    29.09.2016-20:10 - DEBUG - Apache restart return value is: 1
    29.09.2016-20:10 - DEBUG - Apache online status after restart is: down
    29.09.2016-20:10 - WARNING - Apache did not restart after the configuration change for website cbsindia.in. Reverting the configuration. Saved non-working config as /etc/apache2/sites-available/cbsindia.in.vhost.err
    29.09.2016-20:10 - WARNING - Reason for Apache restart failure:  * Restarting web server apache2
    [Thu Sep 29 20:10:02 2016] [warn] NameVirtualHost *:443 has no VirtualHosts
    ... waiting .[Thu Sep 29 20:10:04 2016] [warn] NameVirtualHost *:443 has no VirtualHosts
    Action 'start' failed.
    The Apache error log may have more information.
       ...fail!
     
    nokia80 likes this.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The apache config gets reverted when the written config is invalid, in your case the most likely problem is a missing or broken SSL cert as apache can not start when letsencrypt delivered an invalid cert or when the cert is missing.

    1) Disable the ssl and letesencrypt checkbox of the website.
    2) If a ssl cert is shown on the ssl tab, then empty all fields on the ssl tab. select delete certificate as action and press save.
    3) Enable the letsencrypt checkbox again. Do not do anything on the ssl tab as this might corrupt the new cert again.
     
  11. pawan

    pawan Member HowtoForge Supporter

    Hi Till
    I followed your instructions exactly as you mentioned.
    But I am still getting the same error in the logs. I putting it here.
    Code:
    29.09.2016-23:30 - DEBUG - exec: usermod --groups sshusers web27 2>/dev/null
    29.09.2016-23:30 - DEBUG - Create Let's Encrypt SSL Cert for: cbsindia.in
    29.09.2016-23:30 - DEBUG - Let's Encrypt SSL Cert domains: cbsindia.in --domains www.cbsindia.in
    29.09.2016-23:30 - DEBUG - exec: /root/.local/share/letsencrypt/bin/letsencrypt certonly -n --text --agree-tos --expand --authenticator webroot --server https://acme-v01.api.letsencrypt.org/directory --rsa-key-size 4096 --email [email protected] --domains cbsindia.in --domains www.cbsindia.in --webroot-path /usr/local/ispconfig/interface/acme
    29.09.2016-23:30 - DEBUG - Creating fastcgi starter script: /var/www/php-fcgi-scripts/web27/.php-fcgi-starter
    29.09.2016-23:30 - DEBUG - Enable SSL for: cbsindia.in
    29.09.2016-23:30 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/cbsindia.in.vhost
    29.09.2016-23:30 - DEBUG - Apache status is: running
    29.09.2016-23:30 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    29.09.2016-23:30 - DEBUG - Restarting httpd: service apache2 restart
    29.09.2016-23:30 - DEBUG - Apache restart return value is: 1
    29.09.2016-23:30 - DEBUG - Apache online status after restart is: down
    29.09.2016-23:30 - WARNING - Apache did not restart after the configuration change for website cbsindia.in. Reverting the configuration. Saved non-working config as /etc/apache2/sites-available/cbsindia.in.vhost.err
    29.09.2016-23:30 - WARNING - Reason for Apache restart failure:  * Restarting web server apache2
    [Thu Sep 29 23:30:13 2016] [warn] NameVirtualHost *:443 has no VirtualHosts
    ... waiting [Thu Sep 29 23:30:14 2016] [warn] NameVirtualHost *:443 has no VirtualHosts
    Action 'start' failed.
    The Apache error log may have more information.
       ...fail!
    29.09.2016-23:30 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    29.09.2016-23:30 - DEBUG - Restarting httpd: service apache2 restart
    29.09.2016-23:30 - DEBUG - Processed datalog_id 19046
    29.09.2016-23:30 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    29.09.2016-23:31 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    29.09.2016-23:31 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
     
  12. pawan

    pawan Member HowtoForge Supporter

    I am adding the apache error logs, if that will be of any help.
    Code:
    [Thu Sep 29 23:27:03 2016] [notice] FastCGI: process manager initialized (pid 25909)
    [Thu Sep 29 23:27:03 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Thu Sep 29 23:27:03 2016] [notice] Apache/2.2.22 (Ubuntu) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.3.10-1ubuntu3.24 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.22 OpenSSL/1.0.1 configured -- resuming normal operations
    [Thu Sep 29 23:29:02 2016] [notice] caught SIGTERM, shutting down
    [Thu Sep 29 23:29:03 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Thu Sep 29 23:29:03 2016] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Thu Sep 29 23:29:03 2016] [notice] Digest: generating secret for digest authentication ...
    [Thu Sep 29 23:29:03 2016] [notice] Digest: done
    [Thu Sep 29 23:29:03 2016] [notice] FastCGI: process manager initialized (pid 27343)
    [Thu Sep 29 23:29:03 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Thu Sep 29 23:29:03 2016] [notice] Apache/2.2.22 (Ubuntu) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.3.10-1ubuntu3.24 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.22 OpenSSL/1.0.1 configured -- resuming normal operations
    [Thu Sep 29 23:30:13 2016] [notice] caught SIGTERM, shutting down
    [Thu Sep 29 23:30:22 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Thu Sep 29 23:30:22 2016] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Thu Sep 29 23:30:22 2016] [notice] Digest: generating secret for digest authentication ...
    [Thu Sep 29 23:30:22 2016] [notice] Digest: done
    [Thu Sep 29 23:30:22 2016] [notice] FastCGI: process manager initialized (pid 28632)
    [Thu Sep 29 23:30:22 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Thu Sep 29 23:30:22 2016] [notice] Apache/2.2.22 (Ubuntu) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.3.10-1ubuntu3.24 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.22 OpenSSL/1.0.1 configured -- resuming normal operations
    [Thu Sep 29 23:34:43 2016] [error] [client 91.236.75.4] File does not exist: /var/www/ispconfig/reader
     

Share This Page