Installing Pommo on ISPConfig 3

Discussion in 'General' started by onastvar, Oct 31, 2013.

  1. onastvar

    onastvar Member

    I'm getting lots of errors when I try to install Pommo to my server. Did anyone successfully install Pommo, I would appreciate any suggestions.

    Deprecated: Function set_magic_quotes_runtime() is deprecated in /var/www/clients/client1/web2/web/newsletter/bootstrap.php on line 56 Strict StandardsDeclaration of SafeSQL_MySQL::_sql_escape() should be compatible with SafeSQL::_sql_escape() in /var/www/clients/client1/web2/web/newsletter/inc/lib/safesql/SafeSQL.class.php on line 242 Strict StandardsDeclaration of SafeSQL_ANSI::_sql_escape() should be compatible with SafeSQL::_sql_escape() in /var/www/clients/client1/web2/web/newsletter/inc/lib/safesql/SafeSQL.class.php on line 267 Strict StandardsNon-static method PommoHelper::parseConfig() should not be called staticallyassuming $this from incompatible context in /var/www/clients/client1/web2/web/newsletter/inc/classes/pommo.php on line 71 Strict StandardsNon-static method PommoAPI::getParams() should not be called staticallyassuming $this from incompatible context in /var/www/clients/client1/web2/web/newsletter/inc/classes/pommo.php on line 183 Strict StandardsNon-static method PommoAPI::configGetBase() should not be called staticallyassuming $this from incompatible context in /var/www/clients/client1/web2/web/newsletter/inc/classes/pommo.php on line 192
    Strict Standardscall_user_func() expects parameter 1 to be a valid callbacknon-static method Pommo::_T() should not be called statically in /var/www/clients/client1/web2/web/newsletter/inc/lib/smarty-plugins/gettext/block.t.php on line 107 Strict Standardscall_user_func() expects parameter 1 to be a valid callbacknon-static method Pommo::_T() should not be called statically in /var/www/clients/client1/web2/web/newsletter/inc/lib/smarty-plugins/gettext/block.t.php on line 107 Page fueled by poMMo mailing management software
    Thanks in advance.
    Last edited: Oct 31, 2013
  2. onastvar

    onastvar Member

    After more digging, Pommo only works with PHP 5.3 version or below. After I installed additional PHP version (PHP 5.3.22) on my server I got rid of php errors and warnings. Also I had to comment out line 56 in bootstrap.php file to make Pommo work.


Share This Page