installing php 5.6.30 on ubuntu xenial 16:04 con ispconfig 3.2

Discussion in 'General' started by mircopoint, Mar 6, 2017.

  1. mircopoint

    mircopoint New Member

    [​IMG]

    I was following the guidance to install php 5.6 on Ubuntu 16.04 server with ispconfig 3.1.2 but different steps do not work, initially did not perform the link, with the command: # ln -s /usr/lib/libc-client.a / usr /lib/x86_64-linux-gnu/libc-client.a, then it does not work then the make command.

    probably the guide is for super power users, and I am a regular user!

    thank you
     
  2. ahrasis

    ahrasis Active Member

    Last time I tried the tutorials (I am also using Ubuntu 16.04), it works just fine. May be there is a step or two that you missed?

    However, currently I am using ondrej ppa as it is easier for me, though it is not advisable to rely to it as it is maintained by third party. I have posted a reply in here about how to install and use it to install php7.1. Installing it for php5.6 should be quite the same.
     
  3. mircopoint

    mircopoint New Member

    hello, thank you for your reply, I have followed this guide, because the
    Work on a production server, and I can not risk to block something. It would be a serious problem!
    However, despite the steps are right I can not launch this "make install"
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    According to the compile output, the openssl dev library package seems to be missing on your server.
     
  5. mircopoint

    mircopoint New Member

    it is true, the openssl error is present, but I thought it was the cause of the problem, I have followed your excellent the perfect server tutorial, and everything works fine, I wanted to put php5.6 for old sites.
    However, I checked the package is installed.:(

    # openssl is already the newest version (1.0.2g-1ubuntu4.6).
     
  6. ahrasis

    ahrasis Active Member

    What abouts its library? May be you could try: "apt-get install libssl-dev"
     
  7. mircopoint

    mircopoint New Member

    Hello, I had already checked, as openssl is all installed, in fact I do not understand the problem.

    # libssl-dev is already the newest version (1.0.2g-1ubuntu4.6).
    # [email protected]:~$ openssl version
    OpenSSL 1.0.2k 26 Jan 2017
     

Share This Page