installing Perl module GD - ran into problems

Discussion in 'Installation/Configuration' started by Ovidiu, Sep 18, 2006.

  1. Ovidiu

    Ovidiu Active Member

    here is the output:

    I then found my mistake: I had libgd installed instead of libgd2 so when installing libgd2 php4-gd got removed???

    Now I have no GD support for php? How can I fix this? Any ideas?
    I just found out it was only libgd2-dev conflicting so I deinstalled that one and could install php4-gd still phpinfo does not show me the GD information???? PLEASE help ;-)
    Last edited: Sep 18, 2006
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Isn't there also a package php4-gd2 for gd2 support?
  3. Ovidiu

    Ovidiu Active Member

    I cannot find one :-(
  4. sjau

    sjau Local Meanie Moderator

    Are you on debian or debian-like system?
  5. Ovidiu

    Ovidiu Active Member

    oops, I am using debian 3.1
  6. Ovidiu

    Ovidiu Active Member

    hi there, it seems a libgd-dev package was conflicting with php4-gd, I managed to reinstall php4-gd but still it shows no support for gd inside my phpinfo.

    do I have to somehow enable it? or should installing suffice?
  7. Ovidiu

    Ovidiu Active Member

    strange I had to go to /etc/php4/apache2/php.ini and uncomment this line:

    now it works...

Share This Page