Installing OpenLaszlo with Tomcat using Virtual Host

Discussion in 'Installation/Configuration' started by jacobhenry, Nov 5, 2006.

  1. jacobhenry

    jacobhenry New Member

    I have successfully followed the tutorial for Configuring Tomcat5 and Apache2 with Virtual Hosts using mod_jk with ISPConfig. Now I am given the task of installing OpenLaszlo on my server but have had no luck following the standard installation instructions. The instructions tell me to first deploy the .war file and then simply test the installation. First I placed the .war file in my CATALINA_HOME/webapps/ folder and restarted apache2 along with tomcat. The .war file extracted properly so I proceeded to copy the extracted file into my var/www/web1/web/ directory. Unfortunatly, when I run the application, the .lzx and .lzo extensions are not recognized by the servlet so I am given the option to open or save the file itself. The /WEB_INF/web.xml file identifies these extensions but the servlet is not being called. Any suggestions would be greatly appreciated.
     
  2. edge

    edge Active Member Moderator

    Please do not "double" post (in your case 4 times!) your message!
     
  3. jacobhenry

    jacobhenry New Member

    I apologize. I did not know which area would know the answer (Programming, ISPConfig, General Linux, etc).
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you post your vhost configuration here?
     
  5. jacobhenry

    jacobhenry New Member

    vhost_ispconfig.conf
    Code:
    ###################################
    #
    # ISPConfig vHost Configuration File
    #         Version 1.0
    #
    ###################################
    #
    NameVirtualHost 192.168.2.151:80
    <VirtualHost 192.168.2.151:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.domain.com:80
    ######################################
    #
    #
    <VirtualHost 192.168.2.151:80>
    # Send servlet for context /servlets-examples to worker named worker1
    JkMount  /*/servlet/* worker1
    # Send JSPs  for context /jsp-examples to worker named worker1
    JkMount  /*.jsp worker1
    SuexecUserGroup web1_user web1
    ServerName www.domain.com:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web1/web
    ServerAlias domain.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias  /cgi-bin/ /var/www/web1/cgi-bin/
    <Location /cgi-bin>
    	SetHandler cgi-script
    </Location>
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
    AddType text/vnd.wap.wml .wml
    AddType text/vnd.wap.wmlscript .ws .wmlscript
    AddType image/vnd.wap.wbmp .wbmp
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    </VirtualHost>
    #
    #
    #
    
    I am able to run the JSP and Servlet examples provided by Tomcat. However, the images on the default Tomcat page do not display correctly. Should the pictures show up?

    I am a bit confused how OpenLaszlo works but I assume that is uses a servlet to compile the .lzx files into a .swf file.
     
    Last edited: Nov 7, 2006
  6. jacobhenry

    jacobhenry New Member

    Sorry for the trouble. I just need to add
    Code:
    JkMount  /*.lzx worker1
    
    to my vhost_ispconfig.conf
     

Share This Page