Installing odoo with https and ispconfig

Discussion in 'General' started by Enrique García, Aug 19, 2020.

  1. Enrique García

    Enrique García Member HowtoForge Supporter

    Hi, I use this link for installing https://www.howtoforge.com/community/threads/server-application-software-ispconfig.72690/
    I ran odoo without problems with "python3 odoo-bin --addons-path=addons --proxy-mode -d web1" sucessfully, but with "https://mypage.com:8069" the browser return "ERR_CONNECTION_REFUSED" and the odoo console:
    "2020-08-19 20:11:28,770 7288 INFO ? werkzeug: 189.213.139.223 - - [19/Aug/2020 20:11:28] "üvTh?5¸âe£¤7j2Ú£�8Ò·.�w ¥��� wwevö¹äýÍ~ACø"À+À/À,À0̨̩ÀÀ��/5" HTTPStatus.BAD_REQUEST - - - -
    2020-08-19 20:11:28,771 7288 ERROR ? werkzeug: 189.213.139.223 - - [19/Aug/2020 20:11:28] code 400, message Bad request version ('¸') - - -"
    and other ugly thins :(

    With "http://mypage.com:8069" run with no problems.
    Any idea.

    Regards,
     
  2. Enrique García

    Enrique García Member HowtoForge Supporter

    As an update
    In ispconfig web domain->options->Apache Directives I put:

    ProxyPreserveHost On
    ProxyRequests Off
    <Proxy *>
    Order deny,allow
    Allow from all
    </Proxy>
    ProxyPass / http://127.0.0.1:8069/
    ProxyPassReverse / http://127.0.0.1:8069/

    But checking at the mydomain.com.vhost file, this configuration appears on port 80 and port 443.
    This is correct? or could be an error from ispconfig?

    Regards,
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This is correct, anything that you enter in that field is included in the HTTP and https vhost.
     

Share This Page