Installing multiple PHP versions - missing event.h

Discussion in 'Plugins/Modules/Addons' started by Kronz, Jul 9, 2017.

  1. Kronz

    Kronz New Member

  2. Kronz

    Kronz New Member

    Just to add, I tried installing libevent, libevent-dev, kqueue and kqueue-dev, which supposedly should provide sys/event.h, but the program still complains. I also tried apt-file find event.h but no luck.

    can somebody, please please please really tell me which /sys/event.h, time.h and types.h files this thing really needs ? I tried different libraries but it keeps whining about these files and this is really frustrating.
     
    Last edited: Jul 10, 2017
  3. Kronz

    Kronz New Member

    OK so I built it without the flags
    --with imap
    --with imap ssl

    and it built fine, but I would really like to build it properly with IMAP.
     
  4. Kronz

    Kronz New Member

    The solution was to add
    --with-openssl=/usr \
    --with-imap=/usr \

    to the config command and it is now working OK.

    Additionally, the program auto-apt is awesome for resolving dependencies while installing from source.
     
    Jesse Norell likes this.

Share This Page