Installing ISPconfig Sparc end with error.

Discussion in 'Installation/Configuration' started by Kwinten, Dec 20, 2007.

  1. Kwinten

    Kwinten New Member

    Hi there,

    I'm quite new to linux and I hope someone can help me out with this. I've searched the internet but not find any solution.

    I'm trying to install ISPconfig on an Sun netra x1 running Ubuntu 7.04 but so far no success.

    At first ran the setup from my user home folder with sudo and i got the following error:
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installati                                                                          on routine stops here!
    job-working-directory: could not get current directory: getcwd: cannot access parent directories:                                                                           No such file or directory

    At the second try I ran the setup from root.
    The whole install progress goes fine but at the end I get the following error:

    ./setup2: line 862: 8116 Segmentation fault ispconfig_tmp/php/bin/php -n -q
    ./setup2: line 1088: 8153 Segmentation fault /root/ispconfig/php/php -q
    ./setup2: line 1137: /etc/init.d/ispconfig_server: No such file or direct
    Does someone has any clues on this one?

    Thanks in advance.
  2. knomeking913

    knomeking913 New Member

  3. Kwinten

    Kwinten New Member

    Hey, thanks for answering, but I tried that one already :)

    I've let the server cool down for a while (5 months;)), and maybe it helped a bit.
    The error I now get has something to do with compiling openssl.
    I've done some searching and found someone who runs GCC on Solaris and had the same problem. That of because the March command line option don't exists in the solaris GCC. Instead of that you must use "mcpu".
    I've searched through the makefiles of openssl but I can't find something that looks like the march command which I can replace for mcpu.

    Is there anyone out there who has an idea? I really appreciate your help!
    Thanks in advance.

    The error message:
    make[1]: Nothing to be done for `generate'.
    make[1]: Leaving directory `/home/kwinten/install_ispconfig/compile_aps/openssl-0.9.7m/test'
    Configured for linux-sparcv9.
    making all in crypto...
    make[1]: Entering directory `/home/kwinten/install_ispconfig/compile_aps/openssl-0.9.7m/crypto'
    ( echo "#ifndef MK1MF_BUILD"; \
            echo '  /* auto-generated by crypto/Makefile for crypto/cversion.c */'; \
            echo '  #define CFLAGS "gcc -DOPENSSL_SYSNAME_ULTRASPARC -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_NO_KRB5 -march=ultrasparc -DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall -Wa,-Av8plus -DBN_DIV2W -DMD5_ASM"'; \
            echo '  #define PLATFORM "linux-sparcv9"'; \
            echo "  #define DATE \"`LC_ALL=C LC_TIME=C date`\""; \
            echo '#endif' ) >buildinf.h
    gcc -I. -I.. -I../include -DOPENSSL_SYSNAME_ULTRASPARC -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_NO_KRB5 -march=ultrasparc -DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall -Wa,-Av8plus -DBN_DIV2W -DMD5_ASM   -c -o cryptlib.o cryptlib.c
    cc1: error: unrecognized command line option "-march=ultrasparc"
    make[1]: *** [cryptlib.o] Error 1
    make[1]: Leaving directory `/home/kwinten/install_ispconfig/compile_aps/openssl-0.9.7m/crypto'
    make: *** [sub_all] Error 1
    ERROR: Could not make OpenSSL
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
  4. jnsc

    jnsc rotaredoM Moderator

    I also had trouble to get PHP compiling on debian for sparc. But when I tried to enable debugging for PHP, in order to analyze the crash, PHP then suddenly worked. It's now running for some month without any problems.

    For your OpenSSL problem try looking at openssl mailing list, I know that some version do not compile well under sparc.

    This will not help you much, but that is what I experienced.

Share This Page