Installing ISPConfig 3 on Ubuntu 10.04 - Web Interface Blank

Discussion in 'Installation/Configuration' started by ChristianJessen, Oct 21, 2010.

  1. ChristianJessen

    ChristianJessen New Member

    Hi Everybody,
    Im installing ISPConfig for the first time and having a few problem. I have followed this great guide on installing the the perfect server, and everything seems to go allright; until the "installation complete" part..

    When I access I only find a blank page (or server error 500) instead of the expected login form..

    I found the files on the server, but I can't see the problem. Is there anyone who have heard of a problem like this before and a way to find a solution, or have some tips on how I can get it to work?

    Thanks in advance
    Christian Jessen
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try the IP address instead of If you get a 500 error, then take a look at the apache error.log file and post the error message that you find there.
  3. ChristianJessen

    ChristianJessen New Member

    Thanks for your answer, foolish of me to forget looking at the error.log file.. Ofcourse it turned out to be open_basedir effect, which I fixed in the vhost config.

    Great to have an answer so fast, thanks for your time.
  4. nsangujm

    nsangujm New Member

    I was able to browse, when there was a single domain , after adding a second domain I could also browse the second site, I then changed file permissions in the directory web4/web. After this changes I cannot brosw the second domain. Below is the error log.

    Note: I use ispconf in digitalocean.
    his when not in object context in /var/www/clients/client1/web4/web/index.php on line 11
    [Mon Aug 10 09:18:09.787394 2015] [fcgid:warn] [pid 2384] [client] mod_fcgid: stderr: PHP Fatal error: Using $t
    his when not in object context in /var/www/clients/client1/web4/web/index.php on line 11
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The permissions of the web folder are correct by default, they should not be changed. Your site can become insecure, you should change the permissions back to the original values. All files and folders inside the web folder shall be owned by the web user and client group of this website. Then you should fix the error in the php code of the index.php file on line 11.

Share This Page