Installing ISPConfig 3 on CentOS 6.4

Discussion in 'Installation/Configuration' started by cmsits, May 11, 2013.

  1. cmsits

    cmsits New Member

    [root@centos1 install]# php -q install.php

    _____ ___________ _____ __ _ ____
    |_ _/ ___| ___ \ / __ \ / _(_) /__ \
    | | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ /
    | | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ |
    _| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \
    \___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/
    __/ |

    >> Initial configuration

    Operating System: Redhat or compatible, unknown version.

    Following will be a few questions for primary configuration so be careful.
    Default values are in [brackets] and can be accepted with <ENTER>.
    Tap in "quit" (without the quotes) to stop the installer.

    Select language (en,de) [en]:

    Installation mode (standard,expert) [standard]:

    Full qualified hostname (FQDN) of the server, eg server1.domain.tld []:

    MySQL server hostname [localhost]:

    MySQL root username [root]:

    MySQL root password []: ***********************

    MySQL database to create [dbispconfig]:

    MySQL charset [utf8]:

    postalias: fatal: open /var/lib/mailman/data/aliases: No such file or directory
    Generating a 2048 bit RSA private key

    postalias: fatal: open /var/lib/mailman/data/aliases: No such file or directory

    How is this fixed. I have done step by step in every detail ???

    Any help or response would be great thanks
  2. Hairy

    Hairy New Member

    I have done about 20 installs now with the setup you are describing. If you follow the guide EXACTLY as it is written you will get that error EVERY time.

    Additionally, my /var/log/ispconfig_install.log contains the following two errors on every install.

    [ISPConfig] - /tmp/ispconfig3_install/install/dist/lib/fedora.lib.php, Line 244: WARNING: Failed to execute the command chmod 755 /var/spool/authdaemon
    [ISPConfig] - /tmp/ispconfig3_install/install/lib/installer_base.lib.php, Line 1489: WARNING: Failed to execute the command adduser apache ispapps
    I would also like to know what these errors are and how to fix them.
    Last edited: May 11, 2013
  3. monkfish

    monkfish New Member

    Have a poke around /var/lib/mailman/data and you might see that aliases is a symlink to /etc/mailman/aliases

    If /etc/mailman/aliases isnt there then mailman "should" create it when you add your first mailing list.

    If the alias file isn't present; ie you havent got any lists, then the worst that willl probably happen is it moans in /var/log/maillog about missing file thus:

    May 10 14:27:18 server1 postfix/postalias[2948]: fatal: open /var/lib/mailman/data/aliases: No such file or directory
  4. Hairy

    Hairy New Member

    Yes, that it correct. aliases is a symlink to /etc/mailman/aliases.

    The first mailing list was created before installing ISPConfig as described in the tutorial.

    This error doesn't appear anywhere in my /var/log/maillog log file.
  5. monkfish

    monkfish New Member

    Could have sworn when you create your first REAL list (not the mailman admininsitrative list) it populates that file... to check...
  6. Hairy

    Hairy New Member

    Please make sure that you follow the guide EXACTLY as it is written, that way you can properly produce the error that cmsits is referring to, and the two errors that I am referring to in the log.
  7. monkfish

    monkfish New Member

    Hows about this:

    If you run /usr/lib/mailman/bin/genaliases you should find the files aliases and aliases.db are populated correctly in /etc/mailman.

    I got an error when I ran this as /usr/lib/mailman/Mailman/ has an empty DEFAULT_SERVER_LANGUAGE on line 76.

    I set DEFAULT_SERVER_LANGUAGE = 'en' and the script ran producing the above files which will resolve the errors seen.

    However, this appears to insert similar aliases as described in the howto when editing /etc/aliases.

    Which, in turn, begs the question, should that step be reworked instead of altering aliases file running genaliases instead? At this point think we should refer to the developers for some input as to the interaction between mailman and the ispconfig configuration scripts.
  8. Hairy

    Hairy New Member

    That is correct.

    Keep in mind that you CANNOT add the 'en' BEFORE installing ISPConfig as ISPConfig overwrites the file with a new one of it's own when you install ISPConfig. Threfore, that answer cannot prevent the error that displays on the screen during the ISPConfig install.
  9. monkfish

    monkfish New Member

    I'd look at something like "touch /etc/mailman/aliases" then "newaliases /etc/mailman/aliases" to create blank db file then, if all you're after is not seeing the error on the screen during installation.

    At the end of the day, it doesnt prevent correct installation and operation of ISPConfig.
  10. cmsits

    cmsits New Member

  11. tracerbullets

    tracerbullets New Member

    Followed the same howto and the same error, stumbled on fix (that worked for me) here.

    3 commands:
    postmap transport
    postfix reload

    first command gave me an error:
    postmap: fatal: open transport: No such file or directory

    the other two commands no errors

    Re-ran php -q install.php and no
    postalias: fatal: open /var/lib/mailman/data/aliases: No such file or directory

    MySQL database to create [dbispconfig]:

    MySQL charset [utf8]:

    Generating a 2048 bit RSA private key
    writing new private key to 'smtpd.key'

    Hope this helps
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    The command "postmap transport" is not required, as this setup des not use a transport file, its a virtual user setup. The command "newaliases" is run as part of the installation tutorial anyway and postfix is restarted as well, so none of the above commands do any changes compared to the perfect setup guide. So just follow the perfect setup guide closely and your system will work out of the box, There is no need for any additional commands.

Share This Page