Installing billing addon ERROR 1045 (28000)

Discussion in 'Installation/Configuration' started by jboud, Jul 8, 2011.

  1. jboud

    jboud Member

    System debian lenny
    I followed the instructions, but when I issue the command "php install.php" as root i receive:

    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
    ISPConfig Billing module has been installed.

    I checked MySql permissions and they are like they're supposed to be.

    I went in the control panel and checked the billing addon for user admin. The icon appeared but when i clicked on some options i got messages about tables not existing. So i decided to import them manually in the mysql db of ispconfig and it worked.
    The addon seems to be operational now.
    I hope I didn't break anything for the future.

    Not nuclear science, but this info might help someone in the future.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess you changed the mysql root password (might be some time ago) without changing it in the ispconfig configuration file. Please edit the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf and set the new root password there. As you imported the sql dump manually, you dont have to redo the billing plugin installation.

Share This Page