Installing an old PHP5 application within the new ISPConfig server web site plan

Discussion in 'Installation/Configuration' started by vaio1, Mar 16, 2011.

  1. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Hi guys,

    I have a little problem during the migration of the old customers from the old server with ISPConfig 2.2.37 to the ISPConfig

    The software is a Magento version that requires the PHP 5.2.10.

    Now in the new servers we have installed the latest version of ISPConfig 3 and the php version installed in it is the PHP 5.3.3-7.

    The software doesn't work at all. Now the question:

    Is there a way to execute an old PHP software only within a website plan?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can e.g. install a php 5.2 cgi binary beside the normal php 5.3 of the server. Then reconfigure the suphp.conf file so that suphp uses this php binary instead of the php 5.3 one. So when you select suphp in the website settings then, the scripts will be executed with php 5.2 while all other scripts get executed with php 5.3.
  3. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    I have downloaded this file from

    I have upload this file in the /usr/bin folder and set the right permissions and then I have changed the suphp.conf in this way:

    ;Handler for php-scripts
    ;Handler for CGI-scripts
    After those editings I have restart the Apache deamon and set the website with the suPHP mode.

    now I get these errors:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Apache/2.2.16 (Debian) Server at Port 80
    Log file
    [Thu Mar 17 17:03:24 2011] [error] [client] php52-cgi: relocation error: /lib/i686/cmov/ symbol strlen, version GLIBC_2.0 not defined in file with link time reference
    [Thu Mar 17 17:03:24 2011] [error] [client] Premature end of script headers: index.php
    Why I get these errors?

    Last edited: Mar 17, 2011
  4. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    good morning guys, any suggestion?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You use two different paths in the suphp.conf file for the php binary. Check which of them is correct and change the incorrect one. Then restart apache.

    Additionally, the php binary that you downloaded is not compatible with your system. You should find another one that is compiled agaoinst the correct libc version or compile your own copy of php.
  6. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Hi Till,

    thanks for your answer.
    two paths? Where?

    Where I can download the right version for my debian server. I have followed the Debian Multiserver Tutorial. So, I suppose that you know which is the right php binary that I have to download.

    Thanks for your support
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont use php 5.2 on my servers, and the multiserver tutorial does not use it too, so I can not tell you where to find such a binary. It might be that you have to compile one yourself as I mentioned above.
  8. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    No, I mean that you know the Software Infrastructure that the tutorial has created. Anyway how have I to compile one for my server?
  9. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Where can I download the right version of the php 5.2 for a debian server?
  10. byte internet

    byte internet New Member

    You don't need to install php 5.2, you can easily tweak magento 1.3 to work with php 5.3. We blogged about this on We only tested this with Magento 1.3.3, but is not that different.

Share This Page