installing-a-web-email-and-mysql-database-cluster-on-debian-5.0-with-ispconfig-3

Discussion in 'Installation/Configuration' started by trexen, Dec 27, 2010.

  1. trexen

    trexen Member

    Hi,

    I got a litle problem after a flawless installation:

    "http://www.howtoforge.com/installing-a-web-email-and-mysql-database-cluster-on-debian-5.0-with-ispconfig-3-p2"

    I try to enter the ISPconfig admin interface with http://192.168.250.14:8080
    and i got this error in my webbrowser:

    ................................................................................................
    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 72

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 72
    ................................................................................................

    i dident get into any trouble under installation at all.
    i also try to give 'ispconfig'@'localhost' more priveleges and then restart mysql but it dident work.

    -------------
    Debian Lenny 5
    Latest ISPconfig
    -------------

    any sugestion?
    rgds
    Marcus :p
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please check if the database details (password, etc.) are correct in /usr/local/ispconfig/interface/lib/config.inc.php.
     
  3. trexen

    trexen Member

    This is whar i have inte the file:


    ------------------------------------------
    //** Database
    $conf['db_type'] = 'mysql';
    $conf['db_host'] = 'localhost';
    $conf['db_database'] = 'dbispconfig1';
    $conf['db_user'] = 'ispconfig';
    $conf['db_password'] = 'xxxxxxxxxxxxxxxxxxxxxx';
    $conf['db_charset'] = 'utf8'; // same charset as html-charset - (HTML --> MYSQL: "utf-8" --> "utf8", "iso-88
    59-1" --> "latin1")

    define('DB_TYPE',$conf['db_type']);
    define('DB_HOST',$conf['db_host']);
    define('DB_DATABASE',$conf['db_database']);
    define('DB_USER',$conf['db_user']);
    define('DB_PASSWORD',$conf['db_password']);
    define('DB_CHARSET',$conf['db_charset']);


    //** Database settings for the master DB. This setting is only used in multiserver setups
    $conf['dbmaster_type'] = 'mysql';
    $conf['dbmaster_host'] = '';
    $conf['dbmaster_database'] = 'dbispconfig';
    $conf['dbmaster_user'] = '';
    $conf['dbmaster_password'] = 'xxxxxxxxxxxxxxxxxxxxxxxxx';
    -----------------------------------

    i have no clue what the ispconfig passwd is.
     
    Last edited by a moderator: Dec 29, 2010
  4. trexen

    trexen Member

    Any suggestion about this problem, is the syntax correct for my setup ore wrong?
    I looking forward to have this setup to work correctly =)

    rgds
    Marcus
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Does connecting to MYSQL on the command line work?
    Code:
    mysql -u ispconfig -p
    Does the MySQL password for the user ispconfig contain any special characters?
     
  6. trexen

    trexen Member

    Yes yes its works connection but i dont got the passwd for ispconfig user.
    but i can change it, but i dont know if i destroy some other things if i change, am i?

    rgds
    Marcus
     
  7. falko

    falko Super Moderator ISPConfig Developer

    You can change the password, but keep in mind that you have to add the new password in /usr/local/ispconfig/interface/lib/config.inc.php as well.
     

Share This Page