Installing A Bind9 Master/Slave DNS System

Discussion in 'HOWTO-Related Questions' started by eff3, Nov 25, 2007.

  1. eff3

    eff3 New Member

    Hello together,

    I'm ashamed to place this question to such an really good tutorial but there is a big Problem in my configuration and I'm going to be crazy soon.

    I've found this tutorial in the net and doing this on 2 different machines and it all WORKS fine at the first go. The next step was to reinstall the first machine (NS1) because accidently the gnome gui was installed with an on a running system should be no graphical interface in my opinion.

    As the system was reinstalled I worked out the tutorial again and suddenly there appears a failure message in the syslog

    Code:
    Nov 25 16:18:07 ns2 named[25837]: starting BIND 9.4.1-P1 -u bind -t /var/lib/named
    Nov 25 16:18:07 ns2 named[25837]: found 1 CPU, using 1 worker thread
    Nov 25 16:18:07 ns2 named[25837]: loading configuration from '/etc/bind/named.conf'
    Nov 25 16:18:07 ns2 named[25837]: listening on IPv6 interfaces, port 53
    Nov 25 16:18:07 ns2 named[25837]: listening on IPv4 interface lo, 127.0.0.1#53
    Nov 25 16:18:07 ns2 named[25837]: listening on IPv4 interface eth0, 192.168.0.5#53
    Nov 25 16:18:07 ns2 named[25837]: automatic empty zone: 254.169.IN-ADDR.ARPA
    Nov 25 16:18:07 ns2 named[25837]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
    Nov 25 16:18:07 ns2 named[25837]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
    Nov 25 16:18:07 ns2 named[25837]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
    Nov 25 16:18:07 ns2 named[25837]: automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
    Nov 25 16:18:07 ns2 named[25837]: automatic empty zone: D.F.IP6.ARPA
    Nov 25 16:18:07 ns2 named[25837]: automatic empty zone: 8.E.F.IP6.ARPA
    Nov 25 16:18:07 ns2 named[25837]: automatic empty zone: 9.E.F.IP6.ARPA
    Nov 25 16:18:07 ns2 named[25837]: automatic empty zone: A.E.F.IP6.ARPA
    Nov 25 16:18:07 ns2 named[25837]: automatic empty zone: B.E.F.IP6.ARPA
    Nov 25 16:18:07 ns2 named[25837]: command channel listening on 127.0.0.1#953
    Nov 25 16:18:07 ns2 named[25837]: command channel listening on ::1#953
    Nov 25 16:18:07 ns2 named[25837]: zone 0.in-addr.arpa/IN: loaded serial 1
    Nov 25 16:18:07 ns2 named[25837]: zone 127.in-addr.arpa/IN: loaded serial 1
    Nov 25 16:18:07 ns2 named[25837]: zone 255.in-addr.arpa/IN: loaded serial 1
    Nov 25 16:18:07 ns2 named[25837]: zone localhost/IN: loaded serial 1
    Nov 25 16:18:07 ns2 named[25837]: running
    Nov 25 16:18:07 ns2 named[25837]: zone linux.lan/IN: Transfer started.
    Nov 25 16:18:07 ns2 named[25837]: transfer of 'linux.lan/IN' from 192.168.0.4#53: connected using 192.168.0.5#33492
    Nov 25 16:18:07 ns2 named[25837]: dumping master file: /etc/bind/zones/tmp-fmX3R14Uiv: open: permission denied
    Nov 25 16:18:07 ns2 named[25837]: transfer of 'linux.lan/IN' from 192.168.0.4#53: failed while receiving responses: permission denied
    Nov 25 16:18:07 ns2 named[25837]: transfer of 'linux.lan/IN' from 192.168.0.4#53: end of transfer
    
    Now I rechecked the configuration twice, changing the keys and reinstalled the system again but there is this still this annoying message :confused:

    I really hope you have some ideas to solve that :(
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /etc/bind/zones
    ?
     
  3. eff3

    eff3 New Member

    this is the Output

    drwxrwxrwx 2 root bind 4096 2007-11-17 18:33 .
    drwxr-sr-x 3 bind bind 4096 2007-11-25 16:12 ..
    -rw-r--r-- 1 root bind 710 2007-11-17 18:33 master_linux.lan
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please try
    Code:
    chmod 755 /etc/bind
     

Share This Page