installed CentOS ...

Discussion in 'Server Operation' started by estokwa, Aug 15, 2006.

  1. estokwa

    estokwa New Member

    i just recently installed centos 5 and followed the step-by-step procedures, i tried to access my www.domain.tld but sad to say i just prompted "unable to connect", but when is access it using the localhost on my browser the "apache 2 test page" is showing. i tried to edit the httpd.conf but sometimes i cannot access the internet at all.

    please help me. thanks.
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    What does netstat -tap tell? Is Apache also listening on the external IP?

    any iptables rules? (-> iptables -L)

    Can you post the top part of the httpd.conf where the listening stuff is written?
     
  3. estokwa

    estokwa New Member

    first this is the result of netstat -tap

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:32769 *:* LISTEN 1838/rpc.statd
    tcp 0 0 *:mysql *:* LISTEN 2137/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1818/portmap
    tcp 0 0 *:ftp *:* LISTEN 2221/proftpd: (acce
    tcp 0 0 192.168.1.100:domain *:* LISTEN 2004/named
    tcp 0 0 localhost.mydomain:domain *:* LISTEN 2004/named
    tcp 0 0 localhost.mydomain:ipp *:* LISTEN 1965/cupsd
    tcp 0 0 *:smtp *:* LISTEN 2209/master
    tcp 0 0 localhost.mydomain:rndc *:* LISTEN 2004/named
    tcp 1 0 localhost.mydomain:smtp localhost.mydomain:32858 CLOSE_WAIT -
    tcp 0 0 *:http *:* LISTEN 3809/httpd
    tcp 0 0 *:ssh *:* LISTEN 2017/sshd
    tcp 0 0 *:smtp *:* LISTEN 2209/master
    tcp 0 0 *:https *:* LISTEN 3809/httpd




    for iptables
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    RH-Firewall-1-INPUT all -- anywhere anywhere

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination
    RH-Firewall-1-INPUT all -- anywhere anywhere

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain RH-Firewall-1-INPUT (2 references)
    target prot opt source destination
    ACCEPT all -- anywhere anywhere
    ACCEPT icmp -- anywhere anywhere icmp any
    ACCEPT ipv6-crypt-- anywhere anywhere
    ACCEPT ipv6-auth-- anywhere anywhere
    ACCEPT udp -- anywhere 224.0.0.251 udp dpt:5353
    ACCEPT udp -- anywhere anywhere udp dpt:ipp
    ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
    REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

    i tried to modify my httpd.conf but i am afraid i might end up not accessing the internet at all, i hope i put the rigt info down.

    ServerTokens OS
    ServerRoot "/etc/httpd"
    PidFile run/httpd.pid
    Timeout 120
    KeepAlive Off
    MaxKeepAliveRequests 100
    KeepAliveTimeout 15
    <IfModule prefork.c>
    StartServers 8
    MinSpareServers 5
    MaxSpareServers 20
    ServerLimit 256
    MaxClients 256
    MaxRequestsPerChild 4000
    </IfModule>
    <IfModule worker.c>
    StartServers 2
    MaxClients 150
    MinSpareThreads 25
    MaxSpareThreads 75
    ThreadsPerChild 25
    MaxRequestsPerChild 0
    </IfModule>
    Listen 80


    my first installation of centos works fine, but i want to maximize the full potential of centos thats why i tried to reinstall it again with the help of the info on this site.
    thanks
     
    Last edited: Aug 15, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you post the real address here?
    Is SELinux disabled on your system?
     
  5. estokwa

    estokwa New Member

    good day!!! i just re-installed my server/toy box and gone again to step by step procedures we have here and yes i made it!!!
    thank you......
     

Share This Page