installation problem with php

Discussion in 'Installation/Configuration' started by vatzcar, Jan 20, 2008.

  1. vatzcar

    vatzcar New Member

    hi,
    when i'm trying to install ISPConfig, installation is exiting giving following error:

    Code:
    ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
    
    please help me.

    Edit: Sorry for posting in wrong thread.
     
    Last edited: Jan 20, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    df -h
    ?
     
  3. mselver

    mselver New Member

    I'm having the exact same problem and my output of df -h is:
    /dev/hda1 Size:182G Used:4.8G Avail:168G Use%:3% Mounted on: /
    varrun 252M 88k 252M 1% /var/run
    and so on...

    The rest is 1% use or less.

    Any ideas?

    Milo
     
  4. vatzcar

    vatzcar New Member

    as far my understanding your problem is somewhere else. And that could be solved if you post few lines (may be 10/12) before the error.
     
  5. mselver

    mselver New Member

    I got the update to go through by following Till's instructions on downgrading the gcc and then changing a line in the compile file to ignore checking the gcc. Problem is, now I can't login through port 81 with any username or password I've had, I even changed the password for admin with a mysql command and that didn't help. Also, I can't see the virtual websites outside of my local network. And even inside my local network it's INCREDIBLY slow to resolve the DNS.

    When I first tried to do the update, the update failed with the message from above and removed my ispconfig directory. (Didn't appreciate that much) So is my stuff gone?

    Milo
     
  6. mselver

    mselver New Member

    Ok, I redid the install/upgrade again and reset my router and the websites come up fine, but I still cannot login to the ISPConfig. All I get is ERROR 101: wrong username or password.

    Any thoughts?! Thanks!

    Milo
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you try:

    user: admin
    password: admin

    If this works, your mysql database is most likely empty. Have a look in the /tmp directory, the ispconfig installer should have put a backup of your database there.
     
  8. mselver

    mselver New Member

    I wish it was that easy Till. Not only does admin/admin not work, but I had already checked the /tmp directory and it appears that ispconfig has never made a backup of mysql, even though I've updated 6 or 7 times. When I did this new update and it failed, I reinstalled it again and when it asked for a database name I made it different so that it created a clean one and didn't mess with my old one. What's interesting is, my websites still work, but I can't login still. I think it's muffed pretty good. Thanks for your help man, any other ideas?

    Milo
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    If ISPConfig asked you for a database name, then you did a fresh install and not a update. This results in a system were all old accounts can not be managed with ispconfig anymore. You will have to replace the newly created database with the old database and remove all usernames created by the old ispconfig installation from the file /home/admispconfig/ispconfig/users
     

Share This Page