Installation failes on Debian 11 ISPConfig ai

Discussion in 'Installation/Configuration' started by oscarknijff, Sep 23, 2021.

  1. oscarknijff

    oscarknijff New Member

    Hi!

    I'm running Debian 11 (minimal installation with only standard system utilities installed) on a VPS at VPS hosting provider Strato.
    The ISPConfig auto-install keeps failing on:

    [INFO] Installing packages pure-ftpd-common, pure-ftpd-mysql, awstats, goaccess, awffull
    [ERROR] Exception occured: ISPConfigOSException -> Installing packages failed. (/ispconfig.ai.php:15)

    command started is wget -O - get.ispconfig.org | sh -s -- --no-mail --no-dns --use-php=system --no-quota --debug

    When i run apt install pure-ftpd-common, pure-ftpd-mysql, awstats, goaccess, awffull
    (Sorry, output in Dutch)
    Pakketlijsten worden ingelezen... Klaar
    Boom van vereisten wordt opgebouwd... Klaar
    De statusinformatie wordt gelezen... Klaar
    E: Kan pakket pure-ftpd-common, niet vinden
    E: Kan pakket pure-ftpd-mysql, niet vinden
    E: Kan pakket awstats, niet vinden
    E: Kan pakket goaccess, niet vinden
    (translated: packet not found/ unable to locate packet)

    Tried this also on a VPS with a clean install of Debian 10 and Ubunut 20.04. Also stops at Pure-ftpd...
    Can somebody help me please?

    Cheers, Oscar
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    According to the error message, I would say that the sources.list file does not contain all needed repositories. Maybe Strato removed some commonly installed packages like parts of the apt tools from their OS images. Try to install:

    apt install software-properties-common

    before you run the auto installer. If this does not help, take a look at /etc/apt/sources.list and post its content.
     
    oscarknijff likes this.
  3. oscarknijff

    oscarknijff New Member

    Thanks for your quick reply.
    I've replaced /etc/apt/sources.list before starting the install with:

    deb htp deb.debian.org/debian bullseye main
    deb-src htp deb.debian.org/debian bullseye main
    deb htps deb.debian.org/debian-security bullseye-security main contrib
    deb-src htps deb.debian.org/debian-security bullseye-security main contrib
    deb http deb.debian.org/debian bullseye-updates main
    deb-src htp deb.debian.org/debian bullseye-updates main
    deb htp deb.debian.org/debian bullseye-backports main
    deb-src htp deb.debian.org/debian bullseye-backports main
    (change url in htp beacuse i'm not allowed to post a link yet)

    Tried with apt install software-properties-common but the same result.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Pasting in CODE tags would solve that issue and make the paste more readable.
    What shows
    Code:
    LANG=C apt policy pure-ftpd-common
    and same for the other missing packages.
    That LANG=C before the command makes it output in english so we foreigners understand better.
     
    oscarknijff likes this.
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    By the way, if the server is not in use yet, I would recommend using any other provider than Strato. I have bad experiences with them.
    In the Netherlands, TransIP is one of the best providers. If you want to get something less expensive, use Hetzner.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Try editing sources.list so you have "main contrib non-free" repositories enabled.
     
    oscarknijff likes this.
  7. oscarknijff

    oscarknijff New Member

    New day, new try, better said lots of tries ;-)
    After lots of server rebuild and testing i think i found a solution. For all other Strato VPS admins, here's what i did.

    Rebuild your Strato server with a fresh Debian 10 install.
    I then upgraded this server to Debian 11 following instructions from James Kiarie.
    The only change I’ve made to his instructions is to replace the Strato repositories in /etc/apt/sources.list to:

    Code:
    deb http://deb.debian.org/debian bullseye main contrib non-free
    deb-src http://deb.debian.org/debian bullseye main contrib non-free
    deb https://deb.debian.org/debian-security bullseye-security main contrib non-free
    deb-src https://deb.debian.org/debian-security bullseye-security main contrib non-free
    deb http://deb.debian.org/debian bullseye-updates main contrib non-free
    deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free
    deb http://deb.debian.org/debian bullseye-backports main contrib non-free
    deb-src http://deb.debian.org/debian bullseye-backports main contrib non-free
    After the update proces s finished and the server is rebooted I had to add a temporarily nameserver to /etc/resolv.conf. I’ve used the google nameserver (nameserver 8.8.8.8)

    Then to fix my problem i had to install update-inetd first
    Code:
    sudo apt install update-inetd
    Then start the installer (use --no-quota for your Strato server else the install will fail as well)
    Code:
    wget -O - https://get.ispconfig.org | sh -s -- --no-mail --no-dns --use-php=system --no-quota
    No more errors. So it looks like installing update-inetd did the trick.
    Thanks for the tips and assistance to the 3 T's ;-) Till, Talemann en Th0m
     
    Jesse Norell likes this.

Share This Page