Installation failed: Rspamd & Undefined variable: redhatrel in

Discussion in 'Installation/Configuration' started by postcd, Oct 3, 2019.

  1. postcd

    postcd New Member

    Hello today i ran ISPConfig 3 installer:
    cd /tmp;wget;tar xfz ISPConfig-3-stable.tar.gz;cd ispconfig3_install/install/;php -q install.php

    on my CentOS 6.10 64bit

    Some info messages in my case was:
    "[INFO] service Rspamd not detected"
    "[INFO] haveged not detected - DNSSEC can fail"

    So i additionaly installed haveged (yum install haveged;chkconfig haveged on)
    but can not find how to install rspamd?

    And second thing, the install ended like this:

    Installation ended with error in my case:


    php -q htf-common-issues.php
    PHP Notice: Undefined variable: redhatrel in /tmp/ispconfig3_install/install/htf-common-issues.php on line 179
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's ok, it is not an error.

    The PHP version on your server is too old.
  3. postcd

    postcd New Member

    So how do i proceed?

    $ php -v
    PHP 5.3.3 (cli)

    $ yum remove php
    ---> Package php.x86_64 0:5.3.3-49.el6 will be erased
    ---> Package squirrelmail.noarch 0:1.4.22-5.el6 will be erased

    I followed most recent tutorial for CentOS 6.x that you have suggested at
    It was this one "The Perfect Server – CentOS 6.5 x86_64 (Apache2, Dovecot, ISPConfig 3)"

    it contained instruction to install squirrelmail, so i did, maybe it installed that php version. So how to proceed being on CentOS 6.10 64bit?

    I do not see you mention which PHP version is minimum and you should make your installator script to check the requirement before it start altering my system right? As i do not know now how do i proceed with:

    - upgrading PHP and to which version minimum (yum upgrade php -> No Packages marked for Update;epel repo is available)
    - installing again this crashed installation

    Please kindly let me know what steps to do On my CentOS 6.10 64bit, i will not be using CentOS 7 atm.
    Last edited: Oct 4, 2019
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    So this is a new server? Don't proceed using it, reinstall the server by using CentOS 7. All software in CentOS 6 is too outdated, support for CentOS 6 gets dropped in ISPConfig currently, you would not be able to install any ISPConfig updates on your system in future.
    postcd likes this.
  5. postcd

    postcd New Member

    It is old server with a few installed SW and backups. I do not want to reinstall it nor use ISPConfig for anything serious.
    Possibly i can find some tutorial to upgrade to higher PHP (you have not mentioned which version is required. Possibly it is not known, so i can try 5.6 maybe).
    PHP had problem processing line:
    $pubkeys = [];
    Do you know how to install ISPConfig again after mentioned installation crash?
    php -q uninstall.php says
    Maybe you should remove CentOS 6 Debian 7 etc. tutorials from
    Thanks for your support :)
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not run uninstall, you will not be able to install it or update again after running that script!! Probably you broke it already when you had run it, so the only way to recover the system now is by reverting to a backup. You should find one in /var/backup/ which was created during update.

    Yes, this is the reason, your PHP version does not support the modern syntax.

    This would have been easy when uninstall was not run, simply run the update again after updating PHP. But that's not possible anymore after you had run uninstall.
  7. postcd

    postcd New Member

    Following apparently worked to make ISPConfig running on CentOS 6.10 64bit

    I installed Remi repo and it installed PHP 5.4.45 (cli):
    upgraded php:
    update script:
    (Enter key on everything)
    Then :8080 shows "The requested URL / was not found on this server."
    It complained about Unable to remove the ispconfig-database-user ispconfig Column count of mysql.user is wrong.
    again uninstall:
    (it complained about missing paths.)
    then install:
    And ispconfig seem to be working at https://IP:8080

Share This Page