Installation failed... after Checking for MTA

Discussion in 'Installation/Configuration' started by sushestvo, Oct 11, 2005.

  1. sushestvo

    sushestvo New Member

    I accepted License, then chose language and then this came up:
    Do you accept the licence? [y/n]y

    Please select the installation mode. In expert mode you have to answer some additional questions. In standard mode standard values are assumed for these questions.
    1) standard
    2) expert
    Your Choice: 2

    ########## MAIL SERVER ##########

    Checking for MTA...
    ./setup2: line 349: which: command not found
    ./setup2: line 349: which: command not found
    ERROR: Your system configuration is not compatible with ISPConfig! The installation routine stops here!

    System is FC3 and everything was installed prior running setup.
    What this error means? (line 349)
     
  2. falko

    falko Super Moderator

    It means the program which is missing. Did you follow the tutorial for Fedora Core 3? On page 3 ( http://www.howtoforge.com/perfect_setup_fedora_core_3_p3 ) the program which is installed:
    Code:
    apt-get install which fetchmail wget bzip2 unzip zip nmap openssl lynx fileutils ncftp
    If you didn't follow the tutorial or don't have apt installed, run
    Code:
    yum install which
     
  3. sushestvo

    sushestvo New Member

    I have apt installed.
    And I'm pretty sure I have all those packages installed. Some through Apt, some through yum.
    How can I check if I have a specific package? I would just check for all of them.
     
  4. falko

    falko Super Moderator

    Then run
    Code:
    apt-get install which
    It will tell you if the program is already installed.
     
  5. sushestvo

    sushestvo New Member

    Thanks! Everything was installed fine.
     

Share This Page