Installation errors

Discussion in 'Installation/Configuration' started by Rune, May 15, 2009.

  1. Rune

    Rune New Member

    Followed the tutorial on this page: http://howtoforge.org/perfect-server-debian-lenny-ispconfig3-p5

    No errors on the debian stuff, though I did have to run make twice when installing MyDns

    When I try intalling IspConfig I get these errors:


    /
    Code:
    tmp/ispconfig3_install/install# php -q install.php
    
    
    >> Initial configuration
    
    
    Notice: Undefined variable: distver in /tmp/ispconfig3_install/install/lib/install.lib.php on line 135
    
    Notice: Undefined variable: distid in /tmp/ispconfig3_install/install/lib/install.lib.php on line 135
    
    Notice: Undefined variable: distbaseid in /tmp/ispconfig3_install/install/lib/install.lib.php on line 135
    Linux Distribution or Version not recognized.godzooky:/tmp/ispconfig3_install/install#    

    Any ideas what I need to do to fix this? Some kind of edit to install.lib.php or a missing package perhaps?
     
  2. tio289

    tio289 Member

    I had this problem too.

    I changed the part that finds the Debian version in lib/install.lib.php, line 73, into

    if(trim(file_get_contents('/etc/debian_version')) == '5.0.1' || trim(file_get_contents('/etc/debian_version')) == 'lenny/sid') {



    That solved my problem.
     
  3. Rune

    Rune New Member

    That worked and let me install it ... cheers for that mate :)

    I have a new problem now though, let me login with the default user/password and as expected advised me to change the admin password, which I did

    I also created another admin user at the same time, then I logged out


    Now I can't log in as either 'admin' with both the new and old password, nor can I log in as the second username I created

    Anyone able to help me with that?
     
  4. till

    till Super Moderator

    Looks as if you entered a wrong password or set wrong permissions for the admin user. You should not change the admin user, just change its password. You can try to fix this in the sys_user database table by comparing your user with the one from the sql dump that is in the ispconfig installer.
     
  5. Rune

    Rune New Member

    I didn't change the admin user mate, just changed the admin user's password

    That shouldn't really have locked me out of the admin account

    When I added the second user, I could understand being locked out of that one if I set permissions incorrectly, but again creating a second user with bad options shouldn't have locked me out of the admin account

    If I could get into the admin account I could check out the settings for the new user, but the admin account doesn't accept either the old or the new password

    I'm wondering if the simplest solution wouldn't be to just delete the databases and run the ispconfig installer again, though I will have a look what I can see in the databases when I've a bit more time later today
     
  6. madmac007

    madmac007 New Member

    Centos 5.3

    Same deal here,
    Notice: Undefined variable: distver in /tmp/ispconfig3_install/install/lib/install.lib.php on line 135

    Notice: Undefined variable: distid in /tmp/ispconfig3_install/install/lib/install.lib.php on line 135

    Notice: Undefined variable: distbaseid in /tmp/ispconfig3_install/install/lib/install.lib.php on line 135

    ******when installing on Cenos 5.2 updated to 5.3******

    I modified the line 122, in the same file (/tmp/ispconfig3_install/install/lib/install.lib.php )to

    if(stristr($content,'CentOS release 5.3 (Final)')) {

    Then the install continued.


    Thanks

    madmac
     
  7. Rune

    Rune New Member

    Perhaps the packages in a mirror or two could do with an update to match the latest releases of some distributions

    Been too long a day for me to try fixing my login problem now, started fairly early this morning, finished work and dived straight in the bath, got out and logged into this forum ... it's 1.17 am

    Luckily my name isn't Jack ... or I'd be an extremely dull boy! ;)
     
  8. till

    till Super Moderator

    First, if nobody claims that centos 5.3 is supported by the current stable release, why do you complain that its not suppoerted in the version that you used? Second, there is already a beta version that supports centos 5.3, so if you want to use a linux distribution that is not supported in the last stable relaese, then you can use the beta release.

    http://www.howtoforge.com/forums/showthread.php?t=34555
     
  9. Rune

    Rune New Member

    Fixed that by doing as I said and deleting the databases then re-creating them using the ispconfig install script

    Did exactly the same as last time to change the admin password and create a second admin user (At least I don't recall doing anything differently)

    Worked fine this time and the second user I created does seem to have full admin privs, once I check into that a bit further and I'm sure my new user can do everything I'll disable the original admin user

    Just need to figure out how to use the thing now ...
     

Share This Page