Installation errors: no apache, apache2, etc. & fsockopen()

Discussion in 'Installation/Configuration' started by anushanw, Jan 30, 2009.

  1. anushanw

    anushanw New Member

    I was installing ISPConfig3. I was able to complete all of the required
    steps until I actually start to install ispconfig from install.php file.
    When I type in the command "php -q install.php" it gives me the following
    errors.

    which: no apache in
    (/sbin:/user/sbin:/usr/local/sbin:/root/bin:/urs/local/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/opt/kde3/bin:/usr/lib/jv,/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)

    also I get the same error repeated with the following in the place of
    "apache" and the same paths as mentioned above
    apache2, httpd, couriertcpd, saslauthd, amavisd-new, jk_chrootsh.

    when I continue with the installation it lets me enter the necessary
    information then it installs it but gives me the following error.

    PHP Warning: call-time pass-by-referance has been deprecated; If you would
    like to pass it by reference, modify the declaration of fsockopen(). if you
    would like to enable call-time pass-by-reference, you can set
    allow_call-time_pass_reference to true in your INI files in
    /usr/local/ispconfig/server/mods-available/monitor_core_module.inc.php on
    line 1236
    this message is repeated again and then it is repeated twice again with the
    line number 1248

    when I restart my computer it shows an error on xconsole saying "error
    connecting to MySQL server at localhost: can't connect to local MySQL server
    through socket '/var/lib/mysql/mysql.sock' (2) (errno=2)

    I have zero clue what's going on.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that you dont have apache installed and some other deamons like mysql are missing too. Please follow exactly the installation instructions for ispconfig 3 which can be found in the ispconfig3 tar.gz file to prepare your server befor you try to install ispconfig 3.
     
  3. anushanw

    anushanw New Member

    Till,
    Thanks a lot for taking time to help me out.
    As you mentioned I have installed all those mentioned missing stuff. When i look for the status of them they indicate as "Running". So I doubt that it is the problem.
    However when I installed pam_mysql and tried to setup the password as mentioned in the tutorial, it gave me some error.
    when i typed in "mysqladmin -u root password mypassword" and "mysqladmin -h ispconfig.local -root password mypassword" it gave me an error saying cannot connect.
    Does this have to do anything with the above mentioned?
    Do you happen to know a better tutorial than the Installation Instruction document provided with ISPConfig 3 by any chance?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Which distribution are you using? What's the output of
    Code:
    netstat -tap
    ?
     
  5. anushanw

    anushanw New Member

    here's what i get for "netstat -tap"
    Active internet connections (servers and establishes)
    Proto - have tcp for all lines
    Recv-Q - have 0 for all lines
    Send-Q - have 0 for all lines
    Local Address - *:mysql , *.sunrpc , *:ssh , localhost:ipp , localhost:smtp , *:imaps , *:pop3s , *:pop3 , *:imap , *:ssh , *:ssh , localhost:ipp , localhost:smtp

    Foreign address - have *:* for all the lines
    State - LISTEN for all lines

    PID/Program Name have - 5214/mysqld , 2842/portmap , 2805/sshd , 2856/cupsd , 4508/master , 5374/couriertcpd , 5348/couriertcpd , 5303/couriertcpd , 5318/couriertcpd , 2805/sshd , 4508/master

    I also started a new installation from scartch. here's the error that i have been getting when i typed in "mysqladmin -h ispconfig.local -u root password abc123"
    the error is : "mysqladmin: connect to server at 'ispconfig.local' failed.
    error: 'Lost connection to MySql server at 'reading initial communication packet', system error: 110' "

    when i continue the installation process ignoring the above message i get the following at when i try to start pure-ftpd
    when i type in "/etc/init.d/pure-ftpd start" the following error comes up
    starting pure-ftpd421 unknown authentication method: pam
    startproc: exit status of parent of /usr/sbin/pure-ftpd: 252
    failed
     
    Last edited: Jan 31, 2009
  6. anushanw

    anushanw New Member

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    No. The installation instructions are complete and correct, they include every nescessary step.
     

Share This Page