Installation didn't find files.

Discussion in 'Installation/Configuration' started by Quaxth, Sep 19, 2013.

  1. Quaxth

    Quaxth New Member

    Hello,
    I'm trying to install ISPConfig 3 on CentOS 6.4 x86_64 which were a new and clean install as Basic Server.

    CentOS install just went OK, no problems. Started the Config/Install for ISPConfog 3 using the Installation Guide The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3) and came to point 7 at Page 3

    Import of the RPM GPG KEY went OK. Than I got an error at (see picture)
    [​IMG]
    I also was try the 2. link: http://packages.sw.be/rpmforge-release/ which also didn't works and gave the same error.
    Than the next command: rpm -ivh rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm also just gives an error.

    Could someone pleas explain how to solve that?

    Thanks a lot and I waiting for an response.

    Edit: The picture could seen in full size, this is the direct link to the pcture: http://s20.postimg.org/5rg5abj21/screenshot_291.jpg
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely there are newer versions of the packages available at rpmforge, use the link:

    http://pkgs.repoforge.org/rpmforge-release/

    and search for the "rpmforge-release-" package with the highest ID number and use that one for the rpm -ivh command.
     
  3. Quaxth

    Quaxth New Member

    Thanks a lot Till.

    I'm new to Linux and need to learn all the new way's and commands. So I missed to first use Windows for to search, I was try on CentOS Server!!

    OK, I got the latest version name now and will try to install that one. Hopefully it will works.

    Again thanks a lot and that was just my first question from many to come, me think!

    Cheers.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Just a short note(i know it is a bit late now as you started already), the centos setups are not that easy to install as you have to fiddle around with different repoitorys and possibly conflicting packages. For beginners and administratrs that like to have a easy maintainable system, I would have used a Ubuntu or Debian guide like we recommend it on ispconfig.org.
     
  5. Quaxth

    Quaxth New Member

    Thanks for that Till. Which Debian Distro you suggest? I could just go with it, no problem.

    My biggest concern by this whole installation is the Mail system which is essential and must works with no problems.

    Thanks again and please let me know which version of Debian I should download. I prefer 64bit and the computer is an 4 Core with 16GB Memory.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. Quaxth

    Quaxth New Member

    Thanks a lot Till, I'll than go with it today and see how I could do.

    Cheers.

    Edit: On more question, shouldn't I use the NGINX version? Because it use much less memory and it also should be quite a bit faster than Apache.

    Thanks again.
     
    Last edited: Sep 20, 2013
  8. Quaxth

    Quaxth New Member

    Netinst ISO

    The link provided in the Installation Tutorial didn't work for me I got an 404 Error. So I downloaded the Debian 7.1.0 Netinst ISO (222MB) via Debian.org directly and will use that for to start the installation.

    I hope that's ok, even the provided link pointed to the version 7.0.0.

    Thanks.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats ok.
     
  10. Quaxth

    Quaxth New Member

    Thanks Till.
    I'm in process to install right now Debian 7.1

    What's about the 2 Servers? Which you would recommend. It's about that I'd read about the use of low memory and the increased speed compare to Apache.

    Thanks a lot.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Use apache. On nginx you wont be able to get your sites to work without good Linux and nginx knowledge.
     
  12. Quaxth

    Quaxth New Member

    Thanks Till, I'm on installing and configure.
    Now by mistake (I did) I got an problem with creating the PURE-FTPD.PEM file and it's incomplete. How I could delete that file?
    In real, I don't know the command for to delete a file in Debian.

    Thanks for your help.
     
  13. almere

    almere Member HowtoForge Supporter

    rm -rf /path_to_file/file.bak
     
  14. Quaxth

    Quaxth New Member

    Sorry Till, deleted the file already with the command RM.
     
  15. Quaxth

    Quaxth New Member

    You're absolutely right. It's fun as well, except if the user getting old and still try to learn! I know what I'm talking about because I'm old already!

    Nevermind, slowly I may get to to point where I want to go!

    Cheers!
     
  16. Quaxth

    Quaxth New Member

    I'm now stacks because I get some Apache error, Apache failed to start.

    The Apache Error Log could be found where?

    Thanks.
     
  17. Quaxth

    Quaxth New Member

    I found the Apache Error Log File at /var/log/apache2/error.log

    How I could copy that file to an USB Stick with FAT or NTFS filesystem to get it open in Windows?

    I have an 19" 4:3 Monitor at the Debian Server but the letters are very big and therefore difficult to read such files. And I don't know how to reduce the size of the letters for to get an usable display!

    Maybe I also need to let check that Log file to find out what the hell is hallen

    Thanks a lot for any help.
     
  18. Quaxth

    Quaxth New Member

    As it seems to be that there's maybe now an serious problem with the installation after finishing the Squirrelmail config, which I could not handle, I decided to download Debian 7.0 and do a new full installation with that one.
    Maybe the problem was that I used Debian 7.1 which may have some changes, not covered by the Installation Instruction for Debian 7.0

    For for the help so far, will be just one day more for to try to install ISPConfig 3.
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    DEbian 7.1 is fine. I used the tutorial several timeslast week to install serves. I did a straight copy & paste of all commands, so I'am sure there is no issue in the guide as all servers worked out of the box.
     

Share This Page