Installating Ubuntu on RAID-0 Partition

Discussion in 'Installation/Configuration' started by Shadow1983, Apr 19, 2009.

  1. Shadow1983

    Shadow1983 New Member


    I am really needing help here, i would like to run Ubuntu and Windows XP Pro on my PC. Currently its a RAID-0 config Win XP PC, i tried to create another partition using Partition Magic and that seemed to work ok. I then went to install Ubuntu and all it detected was the 2 Separate HDD's (2 x 160gb) and not any partitions. Its as though it did not detect that there was a RAID-0 config.

    Please can someone help me! To summarise, all i want to do is run both Windows XP and Ubuntu on my system.

    Thank you!
  2. tebokkel

    tebokkel New Member

    You probably don't have hardware RAID0, but software RAID. If you configured SW-RAID from within XP, I don't know, but otherwise (some Intel flexraid or something like that), see if you can use dmraid (look it up).

    Your best bet is probably backup, repartition & reinstall without RAID0. In XP you can mount any (NTFS-)drive in any directory in disk management.

  3. Shadow1983

    Shadow1983 New Member

    No its hardware RAID-0 i bought the PC with it. When i start it up it brings up the RAID config screen (a la dos lol)...
  4. tebokkel

    tebokkel New Member

    Sorry to disappoint you, it's probably not hardware RAID0. It's most likely FakeRAID, otherwise your two drives wouldn't be seen seperately, but as one disk.
    If you didn't pay extra for the RAID0 (RAID1, 1+0, 10, etc) it's probably fakeraid.

  5. Shadow1983

    Shadow1983 New Member

    I did pay extra for it, i bought it from cyberpowersystems:

    It has the raid controler on the start up before it loads windows xp, with it have to hit CTRL+I to enter it.

    I know it isn't software raid...
  6. tebokkel

    tebokkel New Member

    I did the same; paying for it, installing it as a separate controller, connecting disks to it, using it for some time, and than discovering that it is fakeraid. In my case, a Adaptec 1210S. Sold as RAID. It's not.
    A "real" RAID doesn't show the real disks as separate disks to your OS; it is virtualized into a (one) new logical harddisk.

    Doesn't change things, however, Find out if you can use linux dmraid or reinstall. I think repartitioning this system to make room for Linux is too tricky.. (at least for me it would be).

    Good luck!

  7. Shadow1983

    Shadow1983 New Member

    I have checked out my system, during load up it says "Intel Matrix Storage Manager" then it displays which RAID i have, and the two drives which go into it.

    After all of this has loaded and moved on, then it loads up the OS.

    I don't think its software raid...

    Anyway, what is linux dmraid? I did a search and all it bought up were a bunch of command line entries! I have no idea what to do lol.

    My General plan was to partition about 15 gb for linux just so can taste the speed and do general surfing, media viewing etc with it. But i also want to keep xp for all my games and software...

    Sorry to be awkward but i don't really know where else to turn except these help forums...
  8. Jorem

    Jorem New Member

    When you install Ubuntu does the installer also see the Windows partitions as 2 drives? When this is the case you do not have hardware raid. Sorry

    There are some kind of "hardware" raid cards where the software does the Raid. Maybe Windows supports these, but Ubuntu doesn't in this case.

    I had this also with an Adaptec card (like tebokkel) and never got it to work under Linux. In XP it worked.

    If you want to be save you can better put in a hardware raid card like 3ware. They work great with Windows and Linux. And you have a web interface to check your drive status.
  9. Shadow1983

    Shadow1983 New Member

    Well to be honest it seems like too much hassle! More than its worth, i will just have to dig out my ancient IBM lappy and install it on there. Oh well it was worth trying!

    Thanks everyone for your suggestions, i guess linux, on my current setup, was just not meant to be.
  10. Jorem

    Jorem New Member

    Or just add a external harddisk to your pc and install it on there. No Raid problems, or troubles with your Windows Partitions.
  11. Shadow1983

    Shadow1983 New Member

    hmm that could be a plan as i have a 200gb hdd spare anyway, if i bought a hdd enclosure and connected via usb/esata, could i then install it?
  12. Jorem

    Jorem New Member

    I had a Ubuntu installed on my pendrive. I used a guide from this site:

    Dont't forget to do this at the end: # Reboot your computer and set your system BIOS to boot from USB-HDD or USB-ZIP. Also set the "Hard Disk Boot Priority" if necessary.

    * If you really want it on your system you could also setup VMWare player on Windows and make a vm of the Ubuntu system.
  13. 386

    386 New Member

    RAID 0 Linux

    Your problem has nothing to do with using a hardware RAID controller or setting up a RAID device using the Linux mdadm tool. It's that you cannot install the Linux boot loader on a RAID 0 device. You need at least three hard drives to run a Linux machine with RAID 0. I have a setup with a WD Velociraptor HDD for the Ubuntu/Vista dual-boot, two hard drives in RAID 0 for the Vista games and for recording HDTV, and a large capacity HDD for all the photos, documents and MP3 files I process with Ubuntu. I could have set up another RAID 0 device for Ubuntu, but I find I only need the speed to avoid dropped frames recording video and for running some demanding game software - stuff I don't use my Linux OS for. For you, you might want to try installing a switch from your power supply to select between your Win RAID 0 drives and a separate Linux HDD. If you're handy with a drill and a soldering iron, it's not terribly complicated. Done right, you simply switch the PSU to the Win or to the Linux drive(s). At any rate, you have to get a third drive if you want a dual-boot Linux box with a RAID 0 device.

Share This Page