INSTALL_UBUNTU_8.04.txt - horde instructions not clear

Discussion in 'Installation/Configuration' started by snowch, Nov 7, 2009.

  1. snowch

    snowch New Member

    Please see comments below...

    apt-get install horde3 imp4 gollem kronolith2 mnemo2 nag2 turba2
    pear install --onlyreqdeps Log Mail Mail_Mime MDB2 File Date

    It is then necessary to setup an Alias for Apache.
    If you want horde only on single pages, that are created with ispc3:
    Add the following line to ISPConfig->Sites->Web Domain->Options->Apache directives
    If you want to access webmail on all pages add the following line to /etc/apache2/apache2.conf - Does is matter where the line is added in apache2.conf?
    Alias /horde3 /usr/share/horde3

    Allow Apache to write horde configuration files :
    chown -R www-data:www-data /etc/horde

    Important parameters to change are (in Horde setup) :
    How do you access horde setup? /etc/horde/horde3/conf.{xml|php}? or via. a webpage?
    Horde URL (change it to /horde3)
    Enable Database Access. Do Not use MySQL Improved (4+), my attempts at using it failed. MySQL Standard runs fine however
    Enable Authentication. I recommend IMAP authentication (something like {localhost:143/imap/notls}. Do not forget the /notls, not specifying failed on my setup). Also make sure to add your username to the list of Administrators, otherwise, you won’t have access to horde/imp4 parameters. Using anything else than IMAP seeemed to fail on my setup
    Generate the configuration
    Horde should now be setup. You now have to configure imp4
    generate a configuration using the horde administration panel
    modify the /etc/horde/imp4/servers.php file. Instruction are given inside the file concerning the syntax. If you run Courier-IMAP, and want Imp to automatically authenticate using horde credentials :
    $servers[’imap’] = array(
    ‘name’ => ‘IMAP Server’,
    ’server’ => ‘localhost’,
    ‘hordeauth’ => true,
    ‘protocol’ => ‘imap/notls’,
    ‘port’ => 143,
    ‘folders’ => ‘INBOX.’,
    ‘namespace’ => ‘’,
    ‘maildomain’ => ‘’,
    ’smtphost’ => ‘localhost’,
    ’smtpport’ => 25,
    ‘realm’ => ‘’,
    ‘preferred’ => ‘’,
    ‘dotfiles’ => false,
    ‘hierarchies’ => array()
  2. linuxbastard

    linuxbastard New Member

    horde3 configuration issue on 8.04

    I have the same issue.

    I don't get where I'm supposed to change those. I tried dpkg-reconfigure horde3 but that doesn't do anything.
  3. snowch

    snowch New Member

    I gave up on horde and used setup squirrelmail using the instructions for a different operating system (i can't remember which one now).
  4. linuxbastard

    linuxbastard New Member

Share This Page