Install Wordpress on ISPconfig3 (NGINX webserver)

Discussion in 'Installation/Configuration' started by Rashef, Feb 2, 2013.

  1. Rashef

    Rashef New Member

    Sorry to bother again, But NGINX is driving me crazy! :(

    I clueless migrated most of the Wordpress instances on ISPconfig3 running NGINX. Thanks to previous posts and Google I solved all the issues so far.

    Now I need to install a Wordpress from scratch. I created a new website on ISPconfig3, I uploaded the last version of Wordpress and when I try and open index.php (as well as any other address) I get a 500 Internal Server Error.

    I noticed this error in the log:
    Code:
    FastCGI sent in stderr: "PHP message: PHP Warning:  file_exists(): open_basedir restriction in effect. File(wp-config.php) is not within the allowed path(s): 
    I don't really understand this error, but I manually created the wp-config.php anyway. Now I keep getting the Error 500, but there's no error in any log (system, NGINX nor php-fpm).

    Anything else I can try? :-(
     
  2. Rashef

    Rashef New Member

    Let me correct myself! It's not only about Wordpress installation because also the new migration are failing. Precisely, the instances I migrated the very first days are working like a charme, now it looks like every new site (VHOST) could only show the welcome HTML page... :-S

    And I cannot find any error anywhere yet...
     
  3. Rashef

    Rashef New Member

    Ok, I'm trying with a Wordpress, wp-config already configured (otherwise I get open_basedir restriction in effect. File(wp-config.php) is not within the allowed path(s), that I don't understand either). I get 500 Internal Server Error if I try and open index.php. A test PHP page with a PHPinfo works.

    This is the access.log:
    Code:
    [04/Feb/2013:12:50:46 +0100] "GET / HTTP/1.1" 500 1851 "-" "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17"
    Error.log is empty...
     
    Last edited: Feb 4, 2013
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Are there any items listed in the jobqueue in the ispconfig monitor?
     
  5. Rashef

    Rashef New Member

    No it's empty...
     
  6. Rashef

    Rashef New Member

    I have the feeling I'm overshooting some threshold or limit because I already migrated 4 Wordpress instances and 2 single-HTML-page websites flawlessly.

    I'm trying and migrating other Wordpress instances following the same procedure and with the same directives:
    Code:
    location / {
                    try_files $uri $uri/ /index.php?$args;
           }
    
           # Add trailing slash to */wp-admin requests.
           rewrite /wp-admin$ $scheme://$host$uri/ permanent;
    
           location ~*  \.(jpg|jpeg|png|gif|css|js|ico)$ {
                    expires max;
                    log_not_found off;
           }
    fastcgi_buffers 8 16k;
    fastcgi_buffer_size 32k;
    (just in case you're wondering, I also tried with no directives).
    I know that NGINX has this "generic 500 error" as a security measure, but there must be some more specific log, isn't it?
     
  7. Rashef

    Rashef New Member

    After many hours spent on this, I have to give up. I'm afraid that despite the amazing performances I was experiencing with NGINX I'll have to switch back to Apache.

    Thanks for your immeasurable support, as usual!
     
: nginx, wordpress

Share This Page