install trouble

Discussion in 'Installation/Configuration' started by Boon-Dog-Danny, Jul 23, 2006.

  1. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    I want to ask falko ..BRO! WHY ON EARTH DID YOU STOP AT IPSConfig?? the perfect setup for suse10.1 is ..perfect.. exact.. right up until the ipconfig the nothing.. that where you leave us to the wolves..;) kidding you should do a perfect setup with the ipconfig stuff included... anyway

    I've read these forums.. even posted a question (and never seen the post again.. its gone now??) I have the same trouble as others

    first the enter host eg www.. ??? can that be any more confusing? hey I know www.. DONT WORK!!!!! um can someone change that because I see that as the cause of everyone troubles.. because the ONLY thing it takes it the server name.. in my case boonserver..
    but even with that info I have mine all back-arsewards..

    ok here we go..

    I posted before how I had the info messed up could not get stuff to work.. so I reloaded everything after reading ALOT of posts..
    same result.. kinda.

    congrats you did it message said go here.. (by the way I'm posting the real info because I figure its better then the whole abc.com server1.. )

    I named my server boonserver the webdomain name is boon-blog.com
    I have a range of ip's my static for this site is 70.89.119.25 i have 25-29
    subnet 255.255.255.248 gateway 70.89.119.30..

    hummfff.. alas my stuff dont work..
    the boonserver.boon-blog.com:81 dont work

    I can get to the ispconfig panel by
    http://70.89.119.25:81
    but thats it.. the boon-blog.com returns nothing.. www or not
    only the ips work.. same as before, I bought the domain thru netfirms set the dns to the nameservers I got with my ip info.. but it dont work..
    do I have to do something to turn on the domain name itself?

    any help would be great

    thanks
    .. I hope this post dont poof off as well

    as a side question ..how many people are getting good at the terminal.. I know I was scared of it at first and now its my buddy ;) :p
     
  2. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    re

    im thinking I dont have the name server correct..at the net firms place.
    I was reading some forums about an ARecord and and a dig command ...so I tried it and I dont think I have that stuff right. what is the a record..? and what info do I use? do I put the ip the websites static ip?
    when I got my static ips I got static ip's..a gateway ip, subnet 255.255.255.248, and two dns a pri and a sec.. do I put the dns ip's in the a record? I think I have the name server at netfirms pointed the correct way I pretty much did it the same way my other web site is pointed.. but maybe not..


    ; <<>> DiG 9.3.2 <<>>
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16637
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 13, AUTHORITY: 0, ADDITIONAL: 13

    ;; QUESTION SECTION:
    ;. IN NS

    ;; ANSWER SECTION:
    . 48893 IN NS G.ROOT-SERVERS.NET.
    . 48893 IN NS F.ROOT-SERVERS.NET.
    . 48893 IN NS B.ROOT-SERVERS.NET.
    . 48893 IN NS J.ROOT-SERVERS.NET.
    . 48893 IN NS K.ROOT-SERVERS.NET.
    . 48893 IN NS L.ROOT-SERVERS.NET.
    . 48893 IN NS M.ROOT-SERVERS.NET.
    . 48893 IN NS I.ROOT-SERVERS.NET.
    . 48893 IN NS E.ROOT-SERVERS.NET.
    . 48893 IN NS D.ROOT-SERVERS.NET.
    . 48893 IN NS A.ROOT-SERVERS.NET.
    . 48893 IN NS H.ROOT-SERVERS.NET.
    . 48893 IN NS C.ROOT-SERVERS.NET.

    ;; ADDITIONAL SECTION:
    F.ROOT-SERVERS.NET. 543647 IN A 192.5.5.241
    B.ROOT-SERVERS.NET. 543647 IN A 192.228.79.201
    J.ROOT-SERVERS.NET. 543647 IN A 192.58.128.30
    K.ROOT-SERVERS.NET. 543647 IN A 193.0.14.129
    L.ROOT-SERVERS.NET. 543647 IN A 198.32.64.12
    M.ROOT-SERVERS.NET. 543647 IN A 202.12.27.33
    I.ROOT-SERVERS.NET. 543647 IN A 192.36.148.17
    E.ROOT-SERVERS.NET. 543647 IN A 192.203.230.10
    D.ROOT-SERVERS.NET. 543647 IN A 128.8.10.90
    A.ROOT-SERVERS.NET. 543647 IN A 198.41.0.4
    H.ROOT-SERVERS.NET. 543647 IN A 128.63.2.53
    C.ROOT-SERVERS.NET. 543647 IN A 192.33.4.12
    G.ROOT-SERVERS.NET. 543647 IN A 192.112.36.4

    ;; Query time: 47 msec
    ;; SERVER: 68.87.69.146#53(68.87.69.146)
    ;; WHEN: Sat Jul 22 22:27:30 2006
    ;; MSG SIZE rcvd: 436


    and


    boonserver:/home/admin # hostname
    boonserver
    boonserver:/home/admin # hostname -f
    boonserver.boon-blog.com
    boonserver:/home/admin #

    .. first.. I have NO CLUE ..yet.. what I'm doing so know I just figured out how to barely nav with the terminal window.. I'll take any advice..
    I cant seem to get the domain name working.. http://www.boon-blog.com , when I use the ip address http://70.89.119.25:81 I can get to the control login and if I type the address http://70.89.119.25 it gives me a page that says shared?


    oh more info.. I can also login to the ftp using the ip and my admin name and password but Its a public_html I think the info said something/srv or www/srv so I dont think those are matching.. I'm lost..
    so If some kind soul could help point me on the correct path.. I'd be very thankful.
     
    Last edited: Jul 23, 2006
  3. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

  4. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    nope just the one server.. and thanks I think I have the install correct I'm almost positive the trouble is at the whole pointing the name servers and making a ARecord.. I'm lost I see the stuff, read the posts.. the how to's I'm missing what Ip I use? my static IP? thanks TheRudy
     
  5. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    For domain records always use your static/public/router IP..
     
  6. falko

    falko Super Moderator ISPConfig Developer

    You have no A records for boon-blog.com, boonserver.boon-blog.com, www.boon-blog.com, etc., so none of them can work. You can check with
    Code:
    dig yourdomain.com
    We didn't remove any of your posts. It's possible I moved it to another forum if you initially posted in the wrong one.
     
  7. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    thats ok

    oh thats ok.. I think I just lost the link on the last post.. ok.. I think I figured out the whole nameserver deal..yea right ..WOW how confusing.. and I do not think I got it pointed right yet, but it says to wait 24 hours

    ok it starts at netfirms..I bought the domain there.. I park my other site Boon-Dog.com address at hostway.com so i moved the domain control for boon-blog to hostway as well.
    I called business center that provides my connection and ip's and they kinda explained how to make a a record I think I did it because the page use to say shared.. and therudy said thats correct and now its a blank page

    ok so boon-blog.com now is a blank page.. which is good i think.lol

    ok this is where I'm at I can ftp to the ip 70.89.119.25
    that takes me to the first area..root I guess.. the same area as when I login thru puddy.. same place, because when I type in ls I see the same file system. now I seen some folders I recognize public_html, Documents and bin but I've tried to load a index file trying to figure out where I load my files.. no luck there..

    I logged into the ispconfig admin panel thru the ip http://70.89.119.25:81 and I created a admin site I guess and I created a user, and put the info i had in there. now there is a webftp link and after I created me as a user I logged into the webftp and I see another set of files..I tried to upload some simple index pages but still a blank index page. the name http:www.boon-blog.com is now a white page.. no writing so I'm thinking maybe im in the wrong area.
    Falko I tried the dig boon-blog.com and it has some different ip I've never seen or been given so I'm thinking its maybe netfirms host.

    so question.. besides those.. does ipconfig use the ip only? or when I get this name server stuff correct will it use like the domain http://boon-blog.com:81
    because when I finished ipconfig it said go to http://boonserver.boon-blog.com:81 but its not there.. sorry I'm not getting this right away

    where can I check the files on this server to see if I have the correct path to the ftp set right?

    thanks for your help everyone.
     
    Last edited: Jul 26, 2006
  8. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    an update.. hey I got the stuff working.. well somewhat, the http:boon-blog.com now works.. yeah.. but still no www.boo-.. so I have to try and figure out that..

    thanks for everyones help.. anyone know a post that covers adding the www..
     
  9. falko

    falko Super Moderator ISPConfig Developer

    There are still no A records for www.boon-blog.com and boonserver.boon-blog.com:

    Code:
    mh1:~# dig boonserver.boon-blog.com
    
    ; <<>> DiG 9.2.1 <<>> boonserver.boon-blog.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 48847
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;boonserver.boon-blog.com.      IN      A
    
    ;; AUTHORITY SECTION:
    boon-blog.com.          10732   IN      SOA     pri.boon-blog.com. admin.boon-blog.com. 2006072601 28800 7200 604800 86400
    
    ;; Query time: 22 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Thu Jul 27 11:55:00 2006
    ;; MSG SIZE  rcvd: 88
    
    mh1:~# dig www.boon-blog.com
    
    ; <<>> DiG 9.2.1 <<>> www.boon-blog.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31440
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.boon-blog.com.             IN      A
    
    ;; AUTHORITY SECTION:
    boon-blog.com.          10800   IN      SOA     pri.boon-blog.com. admin.boon-blog.com. 2006072601 28800 7200 604800 86400
    
    ;; Query time: 201 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Thu Jul 27 11:55:12 2006
    ;; MSG SIZE  rcvd: 81
    You need to create those A records.
    Also have a look here: http://www.howtoforge.com/traditional_dns_howto
     

Share This Page