Install PHP7-ldap module

Discussion in 'Installation/Configuration' started by bernikm, Feb 12, 2019 at 2:18 PM.

  1. bernikm

    bernikm New Member

    Hi
    We're running ISPConfig 3.1 on CentOS 7. We have 3 PHP versions installed:
    - PHP 5.4.16
    - PHP 7.1.20
    - PHP 7.2.3
    Now we need to enable PHP7-ldap module for one website that is running on PHP 7.2.3.

    I tried to install php72u-ldap module via yum but I got an error below that it conflicts with PHP 5.4.16 ? I don't want to remove PHP 5.4.1.6 since it is still used for some websites running on this server, but I need to install LDAP for PHP 7.2.3 ?
    Is this possible and how ?

    ---> Package php72u-ldap.x86_64 0:7.2.14-1.ius.centos7 will be installed
    ---> Package php72u-common.x86_64 0:7.2.14-1.ius.centos7 will be installed
    --> Processing Conflict: php72u-ldap-7.2.14-1.ius.centos7.x86_64 conflicts php-ldap < 7.2.14-1.ius.centos7
    --> Processing Conflict: php72u-common-7.2.14-1.ius.centos7.x86_64 conflicts php-common < 7.2.14-1.ius.centos7

    Error: php72u-common conflicts with php-common-5.4.16-46.el7.x86_64
    Error: php72u-ldap conflicts with php-ldap-5.4.16-46.el7.x86_64

    Thank you for you help
    Regards,
    Mike
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    How did you install the PHP 7.2 version? If you compiled it manually, then you will probably have to recompile it with ldap support.
     

Share This Page