Install Owncloud Perfect Server 14.04 Apache2

Discussion in 'Server Operation' started by hereinoz, May 11, 2014.

  1. hereinoz

    hereinoz New Member HowtoForge Supporter

    Hi All,

    I am attempting to install Owncloud on an Ubuntu 14.04 "Perfect Server" running Apache2 and ISPConfig3. I have downloaded the web installer and uploaded it to the web directory for one of the sites in ISPConfig3 and run it, but when I click on the first "Next" button in step-1, nothing happens.

    Clearly I have some settings wrong, and I wonder if anyone has any experience in this, and can assist me with where I am going wrong.

    Hope you can help.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    which php ode do you use? The recommended php mode is php-fcgi or php-fpm and suexec should be on. If thats the case and you still get a white page, then check the error.log of this website for errors.
     
  3. hereinoz

    hereinoz New Member HowtoForge Supporter

    Thanks Till, I gave up on the web installer and installed the software from the repository.

    Once I had done that, and copied the ownCloud directory, which had installed itself into the /var/www directory, in to the appropriate /web directory in the /clients tree, it all worked.

    Only with http though - no https.

    I guess I need a certificate & some re-configuration in that web space for https to work. No idea how to do that. I guess that is something for another day. I am not even sure if ownCloud will work with a self signed certificate anyway.
     

Share This Page