Install: nginx invalid parameter ispconfig.vhost

Discussion in 'ISPConfig 3 Priority Support' started by paka, Oct 1, 2013.

  1. paka

    paka New Member

    Just completed a fresh install using the following guide:

    'Debian Wheezy (nginx, BIND, Dovecot, ISPConfig 3)'

    When restarting nginx, returned the following error:

    nginx: [emerg] invalid parameter "on" in /etc/nginx/sites-enabled/000-ispconfig.vhost:3
    nginx: configuration file /etc/nginx/nginx.conf test failed


    Here's the file nginx was complaining about:

    server {
    listen #;
    ssl on;
    ssl_certificate /usr/local/ispconfig/interface/ssl/ispserver.crt;
    ssl_certificate_key /usr/local/ispconfig/interface/ssl/ispserver.key;

    # redirect to https if accessed with http
    error_page 497 https://$host:#$request_uri;

    server_name _;

    root /usr/local/ispconfig/interface/web/;

    client_max_body_size 20M;

    location / {
    index index.php index.html;
    }


    Any suggestions? First time with nginx.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you enterd a "#" instead of the port number (default is 8080) during ispconfig installation.

    As this is a new installation, I recommend to reinstall ispconfig:

    cd into the install folder of the unpacked ispconfig tar.gz again and run the uninstall.php script.

    php uninstall.php

    When the script is finished, run:

    php install.php

    again and ensure that you enter a valid port number like 8080 (or accept the default by pressing enter) during installation. The port number must be a free port, so dont use 80 0r 443 or any other port that is in use already.
     
  3. paka

    paka New Member

    Thank you. Clearly my fumbling fingers hit the '#' key in just prior to reaching 'Enter'. Thought I'd accepted the default.

    Never like it when I'm a plunker, but always like it when someone is kind enough to point out my mistakeeesss;'#

    TA! :)
     

Share This Page