install Mail::ClamAV Fail

Discussion in 'Installation/Configuration' started by Jozzi, Dec 31, 2006.

  1. Jozzi

    Jozzi New Member

    http://www.howtoforge.com/ubuntu6.06_firewall_gateway_p6

    install Mail::ClamAV not work my server (debian sarge)

    I installed this ok to another server, but now install to another server fail:



    Code:
    Manifying blib/man3/Mail::ClamAV.3pm
      /usr/bin/make  -- OK
    Running make test
    PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
    t/Mail-ClamAV....ok 1/10LibClamAV Error: CRITICAL: root == NULL
    t/Mail-ClamAV....NOK 6/10
    #   Failed test 'Scan File'
    #   at t/Mail-ClamAV.t line 97.
    LibClamAV Error: CRITICAL: root == NULL
    t/Mail-ClamAV....NOK 7/10
    #   Failed test 'Scan FileHandle'
    #   at t/Mail-ClamAV.t line 99.
    LibClamAV Error: CRITICAL: root == NULL
    t/Mail-ClamAV....NOK 8/10
    #   Failed test 'Scan File overload'
    #   at t/Mail-ClamAV.t line 102.
    LibClamAV Error: CRITICAL: root == NULL
    t/Mail-ClamAV....NOK 9/10
    #   Failed test 'Scan FileHandle overload'
    #   at t/Mail-ClamAV.t line 105.
    t/Mail-ClamAV....ok 10/10LibClamAV Error: cl_free: root == NULL
    # Looks like you failed 4 tests of 10.
    t/Mail-ClamAV....dubious
            Test returned status 4 (wstat 1024, 0x400)
    DIED. FAILED tests 6-9
            Failed 4/10 tests, 60.00% okay
    Failed Test     Stat Wstat Total Fail  List of Failed
    -------------------------------------------------------------------------------
    t/Mail-ClamAV.t    4  1024    10    4  6-9
    Failed 1/1 test scripts. 4/10 subtests failed.
    Files=1, Tests=10,  1 wallclock secs ( 0.25 cusr +  0.20 csys =  0.45 CPU)
    Failed 1/1 test programs. 4/10 subtests failed.
    make: *** [test_dynamic] Error 4
      /usr/bin/make test -- NOT OK
    Running make install
      make test had returned bad status, won't install without force
    Failed during this command:
      SABECK/Mail-ClamAV-0.17.tar.gz               : make_test NO
    
    Can you help, please!
     
  2. Jozzi

    Jozzi New Member

    i use force install and now it's works fine :p
     
  3. falko

    falko Super Moderator

    Linux is capricious sometimes... ;)
     

Share This Page