Install Freeze

Discussion in 'Installation/Configuration' started by rlhesson, Aug 13, 2006.

  1. rlhesson

    rlhesson Guest

    I have fresh install of Mandriva 2006. Everytime I try to install ispconfig (ive tried version 2.1.0, 2.2.5, 2.2.0, and 2.2.6) the install freezes. And when I say the install freezes I mean it freezes up the whole system and I have to hard reboot. Sometimes it will actually not freeze but cause a hard reboot on its own. I have tried to reinstall mandriva 2006 3 times thinking that might be the problem, same thing happens. Do you have any idea what could be the problem?thanks
     
    Last edited by a moderator: Aug 13, 2006
  2. rlhesson

    rlhesson Guest

    Oh yeah and I am using Mandriva 2006 x86_64 bit version is that whats causing it?
     
  3. rlhesson

    rlhesson Guest

    It has been failing at the same spot during the installation where it is in the openssl directories...I tried following this http://www.howtoforge.com/forums/showthread.php?t=1626 and it got me a little further but still fails in the openssl0.8.9/dsa directory part of the install
     
  4. rlhesson

    rlhesson Guest

    This is where it is failing. It has gotten a little farther than this before but it is always in the openssl section of the install

    ar r ../../libcrypto.a md2_dgst.o md2_one.o
    /usr/bin/ranlib ../../libcrypto.a || echo Never mind.
    make[2]: Leaving directory `/install_ispconfig/compile_aps/openssl-0.9.8b/crypto/md2'
    making all in crypto/md4...
    make[2]: Entering directory `/install_ispconfig/compile_aps/openssl-0.9.8b/crypto/md4'
    gcc -I.. -I../.. -I../../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -m64 -DL_ENDIAN -DTERMIO -O3 -Wall -DMD32_REG_T=int -DMD5_ASM -c -o md4_dgst.o md4_dgst.c
    gcc -I.. -I../.. -I../../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -m64 -DL_ENDIAN -DTERMIO -O3 -Wall -DMD32_REG_T=int -DMD5_ASM -c -o md4_one.o md4_one.c
    ar r ../../libcrypto.a md4_dgst.o md4_one.o
    /usr/bin/ranlib ../../libcrypto.a || echo Never mind.
    make[2]: Leaving directory `/install_ispconfig/compile_aps/openssl-0.9.8b/crypto/md4'
    making all in crypto/md5...
    make[2]: Entering directory `/install_ispconfig/compile_aps/openssl-0.9.8b/crypto/md5'
    gcc -I.. -I../.. -I../../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -m64 -DL_ENDIAN -DTERMIO -O3 -Wall -DMD32_REG_T=int -DMD5_ASM -c -o md5_dgst.o md5_dgst.c
     
  5. rlhesson

    rlhesson Guest

    I was able to get ISPConfig installed on Mandriva 2006 32 bit, but I am still having the same problem on the x86_64 version. I saw that ISPConfig is compatitble with x86_64 so there must be some modifications I need to make that I dont know about. Any help would be appreciated bc I would like to run 64 bit.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the exact error message? I don't see one here.
    I think the problem might be that you must install some openssl-devel packages, for example, on SuSE 10.0 x86_64 you had to install the openssl-devel package for 32bit systems (silly, isn't it?) ( http://www.howtoforge.com/perfect_setup_suse_10.0_p4 )

    I had ISPConfig running on Mandriva x86_64, but I don't remember if I had to install some special packages, or if it worked out of the box...

    You can use urpmi to search for packages. I don't remember the correct command, maybe something like
    Code:
    urpmi --fuzzy [I]search_string[/I]
    See
    Code:
    man urpmi
     
  7. rlhesson

    rlhesson Guest

    there was no error message. It would just freeze the computer there. I will try isntalling some pacakges and see what I can get to work.
     

Share This Page