Install Centos ISPconfig

Discussion in 'General' started by alex288288, Jul 7, 2009.

  1. alex288288

    alex288288 New Member

    Last edited: Jan 19, 2011
  2. edge

    edge Active Member Moderator

    Can you ping any other domain from that system?
    If not your network setup is incorrect
     
  3. alex288288

    alex288288 New Member

    apparently i cant ping anything either, is there a way to fix this?
    the server still works and connects http. and ssh

    this is what i did

    [root@host21 ~]# ping google.com
    ping: unknown host google.com
    ________
    Honda Cr125M
    ________
    Weed
     
    Last edited: Mar 18, 2011
  4. edge

    edge Active Member Moderator

    It looks like your nameserver (DNS) is not set.
    You will need to add a working nameserver in /etc/resolv.conf

    Try using the one from your provider.

    resolv.conf should look something like this
    xx.xx.xx.xx should be an IP from a working nameserver

    When all is done ok, you should be able to ping, and update
     
  5. alex288288

    alex288288 New Member

    ive done this,

    when i goto my conf file i get this info

    ----
    nameserver 208.XX.233.53
    search 127.0.0.1 208.XX.233.53 localdomain
    ----

    should i change the second line also?
    ________
    Daihatsu Hijet Specifications
    ________
    MAZDA C PLATFORM
     
    Last edited: Mar 18, 2011
  6. Mark_NL

    Mark_NL New Member

    you're nameserver is probably down or not responding to queries .. anyway, change it to another ip (or add one).

    you could add some free ns servers

    the "search.." line is optional
     
  7. alex288288

    alex288288 New Member

    hi, mark,

    i have changed my NS back to my IP and it is still not working, i have also enabled Bind Dns Server in hyperVM as it was disabled

    i also noticed when i login to SSH it used to show my IP address..now it shows my old domain name

    root@host21 ~]# wget http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.0.9.tar.gz?download

    it USED to show


    [email protected] ~]# wget http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.0.9.tar.gz?download

    ive also uninstalled Webmin as it WAS installed and i was able to wget ..
     
  8. Mark_NL

    Mark_NL New Member

  9. alex288288

    alex288288 New Member

    hey mark,

    i dont have any DHCP installed.. at least i dont think so,

    this may sound dumb, but how do i go about finding my ISP IP address?
    ________
    Ford futura history
    ________
    Og Kush
     
    Last edited: Mar 18, 2011
  10. Mark_NL

    Mark_NL New Member

    hehe, i've never said DHCP :)

    Anyway, the problem that exists now is that your server can't resolv a hostname (f.e. google.com) to an IP address .. that's when DNS servers come in.

    can you output the content of:
    - /etc/resolv.conf
    - /etc/hosts
    - ifconfig

    and paste them in your reply.

    Also: What ISP is your server connected to? Or is your server located in a datacenter? if so, what's the name of the datacenter?
     
  11. alex288288

    alex288288 New Member

    /etc/resolv.conf
    =nameserver 208.93.233.53
    search 127.0.0.1 208.93.233.53 localdomain

    - /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
    208.93.233.53 host21.info

    -Ifconfig
    [root@host21 ~]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:30:1B:B0:00:E1
    inet addr:208.93.233.53 Bcast:208.93.233.63 Mask:255.255.255.192
    inet6 addr: fe80::230:1bff:feb0:e1/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:24058 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4154 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:3049284 (2.9 MiB) TX bytes:1237742 (1.1 MiB)
    Interrupt:169 Base address:0xa000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:730 errors:0 dropped:0 overruns:0 frame:0
    TX packets:730 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:61712 (60.2 KiB) TX bytes:61712 (60.2 KiB)

    venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
    RX packets:50 errors:0 dropped:0 overruns:0 frame:0
    TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2392 (2.3 KiB) TX bytes:2844 (2.7 KiB)


    ----------------------------

    OOps sorry lol i just noticed you didnt say DHCP :p

    its early here and ive been up all night lol

    anywho this is all my info,

    my Data Centre is :Hostmds (located in Toronto)

    their site: http://hostmds.com

    thanks for any help!
     
  12. Mark_NL

    Mark_NL New Member

    oke it's what i expected ;-)

    Your nameservers are:

    Service FQDN IP Address
    DNS Server #1 ns1.mdswireless.com 208.66.0.95
    DNS Server #2 ns2.mdswireless.com 208.66.0.96
    DNS Server #3 ns3.mdswireless.com 24.215.46.28
    DNS Server #4 ns4.mdswireless.com 24.215.46.29

    open /etc/resolv.conf and make it look like this (remove the "search" line):
    Code:
    nameserver 208.66.0.95
    nameserver 208.66.0.96
    nameserver 24.215.46.28
    nameserver 24.215.46.29
    
    then ping f.e. google.com

    should do the trick
     
  13. alex288288

    alex288288 New Member

    hey thanks for that info i got rid of everything and replaced it with your code ther.

    but it still doesnt work... i really dont know why either. wont ping anyhing. .i tried the wget again, and it still says the same damn thing.. :(

    anyother possbilities???

    greatly appreaciated for the help also\

    im running HyperVM if it makes a diff.. dedicated box though... no vps or anything lol

    regards
    Alex
    ________
    HARLEY-DAVIDSON VRSCD
    ________
    Toys kinky
     
    Last edited: Mar 18, 2011
  14. Mark_NL

    Mark_NL New Member

    paste the output of command: route

    are you able to ping one of the nameservers?

    ping 208.66.0.95

    for example.
     
  15. alex288288

    alex288288 New Member

    i never thought of that.. i CAN ping the NS at ping 208.66.0.95

    here is thr output of -route
    ________
    Vapir no2 vaporizer
     
    Last edited: Mar 5, 2011
  16. Mark_NL

    Mark_NL New Member

    Well, if you can ping 208.66.0.95 (which is the DNS server, then you should be able to ping other things as well).

    try this:

    host www.google.com 208.66.0.95

    if you don't have that cmd, try:

    nslookup www.google.com 208.66.0.95
     
  17. alex288288

    alex288288 New Member

    Last edited: Mar 18, 2011
  18. Mark_NL

    Mark_NL New Member

    i don't get it, you can ping 208.66.0.95
    but cannot resolv google.com ?

    what does "host www.google.com 208.66.0.95" give you then?
     
  19. alex288288

    alex288288 New Member

    when i do that i get

    ----

    [root@host21 ~]# host www.google.com 208.66.0.95
    Using domain server:
    Name: 208.66.0.95
    Address: 208.66.0.95#53
    Aliases:

    www.google.com is an alias for www.l.google.com.
    www.l.google.com has address 64.233.169.99
    www.l.google.com has address 64.233.169.103
    www.l.google.com has address 64.233.169.104
    www.l.google.com has address 64.233.169.147

    ----

    but if i do i simple ping or Wget for ISPconfig.
    (wget http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.32.tar.gz?download) i

    get that same retard error.... failed: Name or service not known.
     
  20. Mark_NL

    Mark_NL New Member

Share This Page