Instalation OK but can not poit any client website

Discussion in 'Installation/Configuration' started by cpaun, Feb 13, 2008.

  1. cpaun

    cpaun New Member

    I did install ISPConfig on new Ubuntu 7.10 withot major problems( thanks to HOWTO forge)
    I did follow all the instruction from ISPConfig Documentation, create resealer, client sites but I can not browse the new client site?
    In client site I did create hostname test1 , domain mytest.com, the IP adress it is 192.168.0.1 ( the ispconfig server ip adress and checked create DNS and DNS-MX. As well in codomain I have mytest.com.
    Now if I open a browser and type eigher test1.mytest.co or mytest.com I get the page can not be displayed.
    Where I am wrong?

    Other confusion on my head it is how to poit the DNS for the clients?
    Lets say I get a ne client and I what to host his wensite on my ISPConfig server.
    I create that client and site, but where the client have to pont his domain on his registry domain? The first DNS will be the ISPconfig server?

    And the last thinks, I have in ISPConfig Management tab, in server settings a tab DNS. I have to ty Default Ns1 and Default NS2. What Ns it is that?

    I really apreciate someone can help me.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely your ispconfig server is not the authoritive dns server for mytest.com. Please login to the interface of the dns server that is authoritive for mytest.com, most likely it is the client interface of the provider were you registered mytest.com and cxreate DNS A-Records for mytest.com and test1.mytest.com that point to the IP address of your server.
     
  3. cpaun

    cpaun New Member

    Thank you Till for your fast answer,
    But still I am confuse.
    First question , the ispconfig machine will act as DNS server as well? Meaning that on the client register first Name server will be onfig name?
    I will give my exact configuration.
    I have ISPconfig installed on ubuntu7.10 on fix ip adress public.
    The name of that is ns2.voipk2.com
    Then I have a client setup on ISPConfig with domain dancepartners.ca
    On the registrar for domain dancepartners.ca the first ns server it is ns2.voip.ca wich are my ISPConfig server.
    NS1-Hostname: ns2.voipk2.com
    NS1-Netaddress:
    NS2-Hostname: everest1.k2systems.ca
    So, the authoritive dns server for dancepartners.ca it is my ISPConfig.
    It is OK as is or I am totaly wrong?


    Thanks
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. cpaun

    cpaun New Member

    Thank you Till,
    I will follow the procedur from your link roday and let you know the results.Just a question.I have to have 2 servers with ISPconfig?
    Can I use my configuration: 1 ISPConfigwith 1 public I and other a linux ( NITIX ) with DNS entry Copy From Nameserver (NS) act as second DNS?

    Thanks again
     
  6. cpaun

    cpaun New Member

    :D Till U are great...
    I did follow the procedures from the link you send me and now I can see my domain dancepartners.ca on my ISPConfig server.
    So I did install 2 servers, buy domain from GoDaddy and I'am in bussiness.
    Now I just have to figure out what webmail it is the best from the client site and how can I use it.
    I did create a resealer, client and site, but I can not login ( how ) on webmail to send and receve emails.
    On dancepartners.ca I have a user cpaun@danceparners.ca.
    Please if you can get me a hint apreciate,


    Thanks again.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You need to create a email user in this site and use the login details for the email user to login to webmail.
     
  8. cpaun

    cpaun New Member

    Can not receive emails on new install

    Thank you Till again,
    I did create a test email acount on each domain.
    Now I am able to login as domain user, I can send email but not receive.
    The domain hosted on ns1.k2systems.net ( ispconfig server) it is dancepartners.ca ( user cpaun) and voipk2.com( user mpaun)
    I did checked if it is listed the ip on black list and seams to be OK
    If I send email to mpaun@voipk2.com i do not get that email back to the sender but also I do not get on my mailbox from voipk2.
    It is any whay to check where stuck that emails ?

    Thanks for your help
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that the MX record for your email domain is pointing to the correct server. You can check this with
    Code:
    dig mx yourdomain.com
    Also, did oyu enable Maildir in ISPConfig (Management > Server > Settings > Email)?
     
  10. cpaun

    cpaun New Member

    I test it and I get that error:

    DiG 9.4.1-P1 <<>> mx dancepartners.ca
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    if I tri dancepartners.ca form same netwotk wit ispconfig server it is OK, but from other netwotk, from internet I get the page can not be displayed.

    Can be because my second name server per that domain it is down?
    I have fisrt name server ns1.k2systems.net ( first ispconfg server ) up and runing and second nameserver ns2.k2systems.net ( second ispcondig server ) down.
    On domain regystry for dancepartner.ca iI have pointed to ns1.k2systems.net
    and ns2.k2systems.net.

    Any ideea where I do thomething wrong?

    Thanks,
     
  11. falko

    falko Super Moderator ISPConfig Developer

    It's working for me:

    Code:
    admin@http1:~$ dig mx dancepartners.ca
    
    ; <<>> DiG 9.3.4 <<>> mx dancepartners.ca
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42711
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;dancepartners.ca.              IN      MX
    
    ;; ANSWER SECTION:
    dancepartners.ca.       86400   IN      MX      10 mail.dancepartners.ca.
    
    ;; Query time: 156 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Fri Feb 22 17:59:07 2008
    ;; MSG SIZE  rcvd: 55
    
    admin@http1:~$ dig mail.dancepartners.ca
    
    ; <<>> DiG 9.3.4 <<>> mail.dancepartners.ca
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61481
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.dancepartners.ca.         IN      A
    
    ;; ANSWER SECTION:
    mail.dancepartners.ca.  86391   IN      A       216.252.71.212
    
    ;; Query time: 1 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Fri Feb 22 17:59:15 2008
    ;; MSG SIZE  rcvd: 55
    
    admin@http1:~$
     
  12. cpaun

    cpaun New Member

    Dig command it is working but I do not get any email

    Thank you Falko for post. I try dig command and it is tru I get same result, but I can not get any email from dancepartners.cq or voipk2.com, both domain from my ns2.k2systems.net ( ispconfig server) It is any log where I can see the reason why I can not receive? To send out mail from those domain it is OK, no problem.
    I have now 3 weeks I try to make thise work and still get problems:eek:
    Realy apreciate for any suggestion.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look in the mail log file, it is located in the directory /var/log/
     
  14. cpaun

    cpaun New Member

    I do have somethink in mail log bu I do not know what I have to have here in order to find the problem why do not receive any email
    I will paste some logs/etc/log/mail.log
    Feb 27 07:32:27 ns1 courierpop3login: Connection, ip=[::ffff:72.10.128.92]
    Feb 27 07:32:27 ns1 courierpop3login: LOGIN, user=web2_cpaun, ip=[::ffff:72.10.128.92]
    Feb 27 07:32:30 ns1 courierpop3login: LOGOUT, user=web2_cpaun, ip=[::ffff:72.10.128.92], top=0, retr=0, rcvd=24, sent=135, time=3
    Feb 27 08:02:25 ns1 courierpop3login: Connection, ip=[::ffff:72.10.128.92]
    Feb 27 08:02:25 ns1 courierpop3login: LOGIN, user=web2_cpaun, ip=[::ffff:72.10.128.92]
    Feb 27 08:02:26 ns1 courierpop3login: LOGOUT, user=web2_cpaun, ip=[::ffff:72.10.128.92], top=0, retr=0, rcvd=24, sent=135, time=1

    mail.info
    27 09:46:52 ns1 freshclam[4607]: Your ClamAV installation is OUTDATED!
    Feb 27 09:46:52 ns1 freshclam[4607]: Current functionality level = 25, recommended = 26
    Feb 27 09:46:52 ns1 freshclam[4607]: DON'T PANIC! Read http://www.clamav.net/support/faq
    Feb 27 09:46:52 ns1 freshclam[4607]: Database updated (220152 signatures) from database.clamav.net (IP: 205.139.192.213)
    Feb 27 09:46:52 ns1 freshclam[4607]: --------------------------------------
    Feb 27 09:48:53 ns1 courierpop3login: LOGIN, user=web2_cpaun, ip=[::ffff:127.0.0.1]
    Feb 27 09:48:53 ns1 courierpop3login: LOGOUT, user=web2_cpaun, ip=[::ffff:127.0.0.1], top=1148, retr=0, rcvd=21, sent=1291, time=0
    Feb 27 09:58:53 ns1 courierpop3login: LOGIN, user=web2_cpaun, ip=[::ffff:127.0.0.1]
    Feb 27 09:58:53 ns1 courierpop3login: LOGOUT, user=web2_cpaun, ip=[::ffff:127.0.0.1], top=1148, retr=0, rcvd=21, sent=1291, time=0

    mail.err.0
    empty
    mail.warn.0

    Feb 24 03:50:09 ns1 postfix/smtpd[18659]: warning: non-SMTP command from 122-116-17-144.HINET-IP.hinet.net[122.116.17.144]: GET http://www.scanproxy.com:80/px_judge.php?p=25 HTTP/1.0
    Feb 24 05:04:31 ns1 freshclam[4492]: Your ClamAV installation is OUTDATED!
    Feb 24 05:04:31 ns1 freshclam[4492]: Local version: 0.92 Recommended version: 0.92.1
    Feb 24 05:04:33 ns1 freshclam[4492]: Your ClamAV installation is OUTDATED!
    Feb 24 05:04:33 ns1 freshclam[4492]: Current functionality level = 25, recommended = 26
    Feb 24 05:58:51 ns1 postfix/smtpd[20363]: warning: 61-228-165-38.dynamic.hinet.net[61.228.165.38]: SASL LOGIN authentication failed: authentication failure


    When I send a email to one of the email account ofthose domain I get after a waile bounce back with following error:
    <mpaun@voipk2.com>:
    irus Scanner<Err>: Anti-virus daemon is not responding.
    MIME Parser<Err>: Scanner not ok. Is kavdaemon running?
    ZDNS Error looking up host IP for voipk2.com
    thank you again fyour help
     
    Last edited: Feb 27, 2008
  15. falko

    falko Super Moderator ISPConfig Developer

    I'm not sure, but htis seems to be a problem on the server that you're using to send to voipk2.com. I can look up voipk2.com fine:

    Code:
    server2:/var/www# dig mx voipk2.com
    
    ; <<>> DiG 9.3.4 <<>> mx voipk2.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24036
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;voipk2.com.                    IN      MX
    
    ;; ANSWER SECTION:
    voipk2.com.             86400   IN      MX      10 mail.voipk2.com.
    
    ;; ADDITIONAL SECTION:
    mail.voipk2.com.        86400   IN      A       216.252.71.212
    
    ;; Query time: 329 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Thu Feb 28 21:36:57 2008
    ;; MSG SIZE  rcvd: 65
    
    server2:/var/www#
     
  16. cpaun

    cpaun New Member

    Yes it is true , was my sender server .With your help and Till I make that working. I have now 2 name server ( ispconfig) on one I will use for production hosting websites for client and one will be just for second name server. Just one question. Can I make the first server to send a copy of all files ( sites and mail ) to second server, but only one will be active, the first one and econd I willl keep uptodate in case the first one it is going down ?
    Do you know how can I make the second name server to act as DDNS for the externam sites ( domain) wich have dynamic IP?


    Thanks again for your help.
     
  17. falko

    falko Super Moderator ISPConfig Developer

    This is complicated. you can try to use a combination of rsync and MySQL replication, and then you have to think of a mechanism to change IP address in the configuration files on the second server (unless server 2 will have the same IP as server 1).
     
  18. cpaun

    cpaun New Member

    Thanks for help

    I did manage to make work ispconfig on my ubuntu 7.10

    Thahns again
     

Share This Page