Inst. stops, MySQL passw not accepted

Discussion in 'Installation/Configuration' started by Thunderbirdsei, Jan 26, 2006.

  1. Thunderbirdsei

    Thunderbirdsei New Member

    Hi!

    I have a problem during the installation. It does not accept my password. But I can logon with the same user and the same password into the mysql admin...what's wrong?

    Code:
    Alle Voraussetzungen erfuellt.
    Here we go...
    Wie heisst der MySQL-Server?mysql
    Wie heisst der MySQL-User?root
    Wie heisst das MySQL-Passwort?
    ERROR 1045 (00000): Access denied for user: [email protected]' (Using password: YES)
    ERROR: Ihr MySQL-Passwort ist falsch! Die Installation bricht hier ab!
    
    [[email protected] install_ispconfig]# mysql -u root -p
    Enter password:
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 5 to server version: 4.1.16
    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    mysql> quit
    
     
  2. str2etboy

    str2etboy New Member

    i would try localhost to the name of the server
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, str2etboy is right, it must be:

    Wie heisst der MySQL-Server?localhost

    please remove the directorys /home/admispconfig and /root/ispconfig before you run the installer again.
     
  4. str2etboy

    str2etboy New Member

    I can solve other's problem, but i cannot deal with my own... ^_^
     
  5. Thunderbirdsei

    Thunderbirdsei New Member

    :D I'm sorry about your problem.....but thank you very much for solving my problem!

    Ok, I'm now a step further...but I'm getting another failure after choosing the SSL-Login mode or is it just a warning?

    Code:
    Connected successfully to MySQL server
    ERROR 1049 (42000): Unknown database 'db_ispconfig'
    Neustart einiger Dienste...
    Shutting down postfix:                                     [  OK  ]
    Starting postfix:                                          [  OK  ]
    Shutting down proftpd:                                     [  OK  ]
    Starting proftpd:                                          [  OK  ]
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result reso urce in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!ISPConfig system is now up and running!
    Herzlichen Glueckwunsch! Ihr ISPConfig-System ist jetzt installiert. Falls Sie Q uota nachinstalliert haben, fuehren Sie noch die in der Installationsanleitung b eschriebenen Schritte durch. Ansonsten ist Ihr System jetzt ohne Reboot einsatzb ereit.
    
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you removed the directories /root/ispconfig, /home/admispconfig, install_ispconfig and the mySQL database before you run the setup script again?
     
  7. Thunderbirdsei

    Thunderbirdsei New Member

    Beside this problem, I can now see the login screen...but with the user name "admin" and the password "admin" I can't login..."Fehler 101: User oder Passwort falsch"...:confused:
     
  8. Thunderbirdsei

    Thunderbirdsei New Member

    yes, I did...with "rm -fr /root/ispconfig" and "rm -f /home/admispconfig" and the "install_ispconfig" directory manually...I didn't found a mySQL database...hmmm

    btw: Thanks for the amazing answer speed!!!
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, thats the problem i sposted above. this happens if you run the setup twice when you have not deleted the directories (as described in the installation manual).

    run:

    rm -rf /root/ispconfig
    rm -rf /home/admispconfig

    Delete the directory that is named like your ISPConfig database in /var/lib/mysql/
    Then unpack the installer tar.gz package again and run the setup script. it shall the run trhouh without problems.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats strange, because the error you posted above occurs when the setup script is trying to update a broken install, that has no database.
     
  11. Thunderbirdsei

    Thunderbirdsei New Member

    Do you mean the whole directory "mysql"?

    Code:
    [root# dir
    ibdata1  ib_logfile0  ib_logfile1  mysql  mysql.sock  test
    
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    No. Did you name your database mysql? Tha was a really bad idea beacuse ISPConfig cannot be installed into existing databases :rolleyes: Please chose for your next install a database name that does not exst yet, like dbispconfig or just ispconfig.
     
  13. Thunderbirdsei

    Thunderbirdsei New Member

    No, I choosed the example name "db_ispconfig". Ok, what can I do? Restart the whole installation? How can I make sure that everything is "fresh"?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that the directories /root/ispconfig and /home/admispconfig does not exist and that there is no database with the name you chose for the ispconfig database in the installer.

    Explanation:

    The ispconfig installer looks for the directories /root/ispconfig and /home/admispconfig, if the directories where there, the installaller switches to update mode.
     
  15. falko

    falko Super Moderator ISPConfig Developer

    You can check your MySQL database with the MySQL commands from this thread: http://www.howtoforge.com/forums/showthread.php?t=1703

    If you want to delete the db_ispconfig database from an unsuccessful previous installation, do it like this:

    Code:
    DROP DATABASE db_ispconfig;
     
  16. Thunderbirdsei

    Thunderbirdsei New Member

    Ok, can I delete everything in the /var/lib/mysql directory? I have there 2 folders "mysql" and "test". In addition there are the files ibdata1 ib_logfile0 ib_logfile1 mysql.sock

    I don't know if the folders where created by a previous test installation or not...
     
  17. Thunderbirdsei

    Thunderbirdsei New Member

    Ahhhhh....Besten Dank!! :D

    Strange..."show databases" => no "db_ispconfig" database....so, why did I receive the failure message...?
     
    Last edited: Jan 26, 2006
  18. Thunderbirdsei

    Thunderbirdsei New Member

    Seriously, I did all again and stock here:

    Code:
    Connected successfully to MySQL server
    ERROR 1049 (42000): Unknown database 'ispconfig'
    Neustart einiger Dienste...
    Shutting down postfix:                                     [  OK  ]
    Starting postfix:                                          [  OK  ]
    Shutting down proftpd:                                     [  OK  ]
    Starting proftpd:                                          [  OK  ]
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!FreshClam is already running!
    ISPConfig system is now up and running!
    Herzlichen Glueckwunsch! Ihr ISPConfig-System ist jetzt installiert. Falls Sie Quota nachinstalliert haben, fuehren Sie noch die in der Installationsanleitung beschriebenen Schritte durch. Ansonsten ist Ihr System jetzt ohne Reboot einsatzbereit.
    
    Code:
    mysql> show databases;
    +----------+
    | Database |
    +----------+
    | mysql    |
    +----------+
    1 row in set (0.00 sec)
    
    mysql>
    
    I can't figure out...it seems, that the database would not being created by the installation routine. I'm a bit down...I just can see the login window but I can't login because it is no database there ^^. I have to say, that I just started with Linux the last few weekends...a big jump for me and now it seems a bit pointless...my goal was a LAMP with Joomla, with mail, virtualhost etc...perhabs I am just too dumb, so I have to stay by server4you.de ...pffff....

    Never mind...speaking a bit to myself...go to bed little boy...^^
     
    Last edited: Jan 26, 2006
  19. adrenalinic

    adrenalinic Member

    I have same problem on my mysql server!
    Access denied for user: '[email protected]'

    But with
    mysql -u root -p
    Enter password:
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 26 to server version: 4.0.24_Debian-10sarge1-log

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

    mysql>
    ____________________________________________________________

    what is operation to make on mysqlserver for work!!?!?!

    Thanks Josef
     
  20. falko

    falko Super Moderator ISPConfig Developer

    Are you sure you used the same password during the ISPConfig setup?
    If so, does your MYSQL password contain special characters like '$%&ยง' and so on?
     

Share This Page