inetd not in /etc/init.d

Discussion in 'Installation/Configuration' started by sajo, Nov 4, 2006.

  1. sajo

    sajo New Member

    I onstall on second box debian sarge by the perfect howt to from falko,
    On first box, no problem but on second box I stoped where it say to restart inetd. There is no inetd in the /etc/init.d

    OK then I made search that file and the file was found in /usr/sbin/ is that normal should I change anything or I can leave like it is and just restart it there.
  2. sajo

    sajo New Member

    One more thing, when I do
    and then I check syslog there it says
    Any help pleaseee.
  3. falko

    falko Super Moderator ISPConfig Developer

    There's something wrong on your system. Where exactly do you have the problem? Is it in the Postfix/POP3/IMAP chapter on ? If so, did you run
    apt-get install postfix postfix-tls libsasl2 sasl2-bin libsasl2-modules ipopd-ssl uw-imapd-ssl
  4. sajo

    sajo New Member

    I done clean instal once again and after install was done I check for inetd location and it is in /usr/sbin/ , so I dont thonk the problem is in postfix because I didnt get there yet. Maybe the problem can be in the source list, because if I leave source list like it is doesnt connect to files to download so I put contrib non-free at the end of lines, so maybe I get different sources and that could be the reason. But what can I do, system wont install if I leave unatched source.list.
  5. falko

    falko Super Moderator ISPConfig Developer

    Please post your sources.list here.
  6. sajo

    sajo New Member

  7. falko

    falko Super Moderator ISPConfig Developer

    Can you try this in /etc/apt/sources.list?

    deb stable main
    deb-src stable main
    deb stable/updates main
    Then run
    apt-get update
    and try to install the missing packages again.
  8. sajo

    sajo New Member

    I did try with this already before, but I get some error I dont remeber exactly but something about connection time out or something like that, however I was unable to start with those sources, I did manualy put source in when instalation asking for instalation way, http ftp ... manual settings, so after few unsucesufful attempts I try with manual sources and I manage to start instalation normaly but then stoped when I try to restart inetd... Well however I try with Ubuntu and everyrhing was OK and server running, but in the future I would like to have debian, so that is why I am still asking. Later I will make test box wih debian again and then will asking you more question. Thanks for now. Hope you will help me again when needed.

  9. falko

    falko Super Moderator ISPConfig Developer

    Does Debian recognize your network card? Maybe the correct driver is missing because it's too new, and therefore you don't have a network connection. What's the output of

    Or maybe your server is behind a proxy?
  10. sajo

    sajo New Member

    Maybe I should start at the begining. So
    I have AMD 1600 Duron and 256 ddr ram and ata HDD 320Gb, asrock motherbord with onboard network card.
    So my initial problem was when I insert CD for web install, the instalation stoped at point where checking for IDE-CDROM, I have NEC dvd ROM, the instalation stoped there and wont go on. So I try to start instalation with kernel 26 at start, everything goes well until instalation start to getting files from internet, also source checking was OK but instalation stoped when trying to get files, afetr long time of waiting instalation goes on but it didnt instal the important files so when I goes with perfect instal it stoped wery soon because there was a lot of missing components. So I restart instalation from begining, use kernel 26 and manual wright sources non free contribute. And instalation goes perfect, then I start wit perfect setup and the first line where it says I have to restart inetd, there was problem again and I stop the instalation because I think that is not ok.

    So network card is not problem also I am doing everything thrue putty so connection is a live an also apt get works with non free contribute source.
    So I am thinking that original kernel from sarge does not support my computor component, and I buy new computor with intel procesor and it was the same problem, so I am thinking once again that kernel form sarge 2.4 is to old for supporting my component. Maybe I should wait for new debian and new how to.
  11. falko

    falko Super Moderator ISPConfig Developer

    Always use kernel 2.6.

    It seems that some of your hardware isn't supported by Debian's kernels.
    What's the output of
    , and what's in /etc/networking/interfaces?
  12. JorisA

    JorisA New Member

    I had the same problem on my fresh install, but it appears mine is using inetutils-inetd. you might check if that one is present.
  13. Randy

    Randy New Member

    Same Here

    Hi All,

    I have the same issue (I've posted in this forum about this also). Regardless which repository you use, apt always selects something else instead of inetd. (usually inetdutils-inetd or yet another one). The thing is the when I installed the same systems about three weeks ago apt normally installed inetd. So I think the change was made by the debian sites.

Share This Page