Index.html returns after delete

Discussion in 'Installation/Configuration' started by redhat66, Feb 6, 2007.

  1. redhat66

    redhat66 New Member


    I have ISPConfig running under "The Perfect Setup - Ubuntu 6.10 Server (Edgy Eft)". The install went VERY well and all works as it should, with one exception.

    It would seem that each time I create, change, or update a domain, user, or site the default "index.html" is recreated in the sites web/ directory.

    This drove me crazy at first but now I know that if I change a setting and "save" I need to go to the sites web/ directory and delete the default "index.html" file.

    Could some one please tell me what is causing this and possably stop it.

    Best regards,
  2. edge

    edge Active Member Moderator

    Withing ISPconfig go to ISP Manager, select the domain > Options, and remove index.html in the DirectoryIndex.

    This should stop the auto creation of the index.html file (I think)
  3. redhat66

    redhat66 New Member

    That did the trick.

    Just for posterity,

    I navigated to Domain > Options and removed “index.html”
    Saved and went to “WebFTP” and logged in.
    The server created another Index.html file.
    I deleted it and went back to the Domain and made and saved changes. Returned to the WebFTP and no index file.

    So it works. I included the above data so no one gets the impression that as soon as you remove the entry from Options this works. The server creates an index file one last time.

    Best regards,

Share This Page