index.html error file for all websites after ISPConfig updated

Discussion in 'ISPConfig 3 Priority Support' started by rodti, Aug 15, 2014.

  1. rodti

    rodti Member

    I've just updated a server to the latest p3 update.

    Since the update all sites on the server show the index.html placeholder file.

    I've checked in each web folder within /var/www and there are no index.html files there.

    The default /var/www/index.html is custom and so I can tell they're not reverting to the default.

    [EDIT: It looks like it actually is hitting the default /var/www/index.html, and the page it redirects to is also affected]

    All sites are in /etc/apache2/sites-enabled.

    Any ideas? This has brought down every website on the server and I'm struggling to figure out what's up!
    Last edited: Aug 15, 2014
  2. rodti

    rodti Member

    I should mention that a slave server with similar configuration has been updated with p3 and is fine.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Check apache2.conf if it contains a include (towards the end of the file) that includes everythig from sites-enabled directory.

    from debian wheezy:

    # Include the virtual host configurations:
    Include sites-enabled/

    the update does not alter any vhost files, so there can be no changes in these files. there must be a problem that apache does not include them at all.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I updated several client systems today as well and did not had any problems yet either. The only problem that can occur with the .htaccess protection is that when a user has a very old password in md5 format and not crypt format, then he cant login to the .htaccess as apache does not support md5. In suche a case the best option is to set the password in ispconfig again, that will store it in the more secure crypt-md5 format.
  5. rodti

    rodti Member

    I've checked apache.conf and the line is present.

    Interestingly https sites are working. I only have one, but it's working.

    I've checked ServerAlias etc in the sites-enabled files, all look fine, I thought that could have been the issue.
  6. rodti

    rodti Member

    I've discovered two misconfigured client .vhost files for sites that (typically) must have been added around the time of the update.

    I'll try and replicate the error and get back to you!
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, maybe a problem with ports or namevirtualhost settings. Please check the ispconfig.conf file in sites-available if it contains all required namevirtualhost lines.
  8. rodti

    rodti Member

    OK, got it.

    Looking at two servers, let's call them server1 (master) and server2 (slave), the control panel has an IP address set up for each of them in System > Server IP addresses.

    If the user is confined to server1 and adds a new site, the IPv4-Address dropdown allows them to select * or the IP address set up in the main config.

    If they pick * everything works fine, but if they pick the IP address this causes an Apache2 configuration issue and everything goes to default.

    I noticed this by running apache2ctl -S which showed the offending sites at the top, with instead of port 80.

    Is there any way I can prevent this other than removing the IP addresses from System setup? It's useful to have those enabled for other parts of the interface, such as the IP dropdown when adding DNS zones.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats the "Dont mix IP address and * problem" in apache. A IP i always a stronger match then a wildcard and apache will forward all traffic to the site that has the IP assigned from the wildcard site.

    You can assign IP addresses to a client. Create a dummy client in ispconfig for that purpose and assign him the IP addresses. they will be still visible for the admin but not for the other clients.
  10. rodti

    rodti Member

    Thanks Till, that's sorted it!

    And the answer to why everything redirected to a mysterious index.html placeholder? Because the misconfigured sites had just been set up!

Share This Page