Increasing email size limit from 10Mb

Discussion in 'Installation/Configuration' started by zetnsh, Apr 21, 2009.

  1. zetnsh

    zetnsh New Member

    Hi there,

    I have a server running ISPConfig 2.2.19. Currently incoming and outgoing e-mails seem to be limited in size to 10Mb. I have tried in the past to increase this limit to 100Mb (safe enough for the traffic the server gets) but when I did, the whole server seemed to spiral out of control and crash, as you obviously have to configure spamd for this as well.

    My (relevant) configuration is this:
    Fedora Core 6
    ISPConfig 2.2.19
    Postfix 2.4.5 (SMTP)
    Dovecot 1.0.3 (IMAP/POP3)
    Spamassassin 3.1.9
    1Gb RAM, 2Gb swap

    Does anyone know the best way to do what I want?

    Thanks in advance,

    Neil
     
  2. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    try to change message size on postfix
    message_size_limit = 10485760 is eqal to 10 Mb
    But i thing 100 MB is very large, you risk that your ip will be on blacklist.
    I recomend size about 50 MB max, that is for one of my customer that have design center, messages above this limit i thing is for other file server service, not for mail.
     
  3. tebokkel

    tebokkel New Member

    And for PHP based webmail you probably also need:
    Code:
    post_max_size = 52M
    upload_max_filesize = 50M
    max_input_time = 600
    or figures like this in your php.ini (likely in /etc/php5/).

    But of course your mailer (Postfix) should also accept the larger sizes.

    Paul
     
  4. zetnsh

    zetnsh New Member

    Thanks for the tips - I hadn't considered that 100Mb would be too big, but I'm sure 50Mb would be fine (50 x 1024 x 1024 = 52428800 bytes) for my application.

    Is the postfix setting the only one I need to change? Do I not need to tweak spamassassin in some way to handle bigger messages, otherwise I might get a backlog?

    Thanks again,

    Neil
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Spamassassin automatically skips messages which ere too large, so there is no additional configuration needed.
     
  6. zetnsh

    zetnsh New Member

    Thanks for your help guys, I got it working, but there's another step!

    I added this to /etc/postfix/main.cf:

    mailbox_size_limit = 0
    message_size_limit = 52428800

    The first command is necessary because first time round postfix refused to start because the default for mailbox_size_limit is slightly less than message_size_limit. I could have set the two values the same which would have worked as I'm using dovecot/imap and postfix is set to deliver each message to a separate file, but the zero value here tells postfix not to limit the size of an individuals mailbox.

    Obviously tweak that setting to suit your setup!
     

Share This Page