Increase email attachment size

Discussion in 'HOWTO-Related Questions' started by mrbronz, Jul 9, 2021.

Tags:
  1. mrbronz

    mrbronz Member HowtoForge Supporter

    I currently have a "Maximum allowed file size is 2.0 MB" for my email

    How do I increase this

    Many thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Where do you see that and which email client you use? Just a guess, you use RoundCube or similar web-based email client and you try to upload a file attachment?
     
  3. mrbronz

    mrbronz Member HowtoForge Supporter

    I'm using Roundcube and it's just to the right-hand side of the interface when I try and attach a file
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    In this case, your problem is the PHP upload size limit. Edit the apache2 php.ini file (the exact path varies depending of Linux distribution and version) and set the

    upload_max_filesize = 10M
    post_max_size = 10M

    (or the value that you need) and restart apache. if you don't know the path to php.ini, then please post which Linux distribution, version and web server you use.
     
  5. FredZ

    FredZ Member HowtoForge Supporter

    Can the email file attachment size be set in the ISPC web UI?
    The assumption here is that roundcube has been installed, and roundcube is reporting the 2Mb limitation.

    Regards

    Fred
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Not to my knowledge.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    What RoundCube reports there is the max upload size of PHP, which also limits attachments as RoundCube is written in PHP. If no files bigger than 2MB can be uploaded by a PHHP script, then no attachment in RoundCube can be bigger than 2MB as well. The global PHP max. upload size can be configured in php.ini only. there is no option for this PHP setting in ISPConfig.
     

Share This Page