Incoming mail bounced: unknown user

Discussion in 'Installation/Configuration' started by Ignacio Garcia, Jan 8, 2018.

  1. Ignacio Garcia

    Ignacio Garcia New Member

    Hi there. I've been using ispconfig3 for years, exclusively under Debian and Ubuntu. I just installed it on Centos 7, following the Perfect Server tutorial for Centos 7.3. Everything seems to be working fine so far, but postfix, which insists in telling me that accounts do not exist when receiving incoming mail. Here's the log.

    Jan 8 19:47:26 isp1 postfix/local[14621]: F339E4420063: to=<testing[at]>, relay=local, delay=0.13, delays=0.04/0.03/0/0.06, dsn=5.1.1, status=bounced (unknown user: "testing")

    (Had to substitute @ for [at] to post this message)

    This message is a response from an outside address from a previously sent message from this account that postfix think it does not exist.

    Can anybody help me find out the problem?


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe you used a wrong hostname? The server hostname may not be a domain that is used for email, it has to be a sub domain like server1.yourdomain.tld but not yourdomain.tld. if you used a wrong hostname, then change it in /etc/hostname, /etc/hosts and /etc/postfix/
    Ignacio Garcia likes this.
  3. Ignacio Garcia

    Ignacio Garcia New Member

    That makes sense. Yes, the hostname is, same in Tomorrow I'll setup a completely different domain and email account.

    Thanks, till
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Using a subdomain like sjould be ok, you just can't use as hostname. Please take a look into the postfix file, is listed there somewhere without the isp1 subdomain part?
    Ignacio Garcia likes this.
  5. Ignacio Garcia

    Ignacio Garcia New Member

    No, actually the hostname in is, /etc/hosts is isp1 and /etc/hostname has the external ip pointing to
    This morning I added a totally different domain, setup an email address, and it's working perfectly. However, I must say that a couple of days ago I setup this testing server with debian 9 and had no problems whatsoever sending and receiving from/to this testing[at] account.
    Nevertheless, although I've noticed that ispconfig3 integration with CentOS is not as tight as with Debian (I've had to end up tweaking things like amavisd config files to make it work), yours is a superb piece of software. Having used Plesk as well I prefer ispconfig3.

    Thanks again for your nice program and impressive support.

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    What did you have to alter in amavisd.conf? I installed an ISPConfig server today and it works fine.
  7. Ignacio Garcia

    Ignacio Garcia New Member

    I'm still testing the server (it's been more than 10 years not playing with a redhat-based system). I found another post in the forum where you recommended using ispconfig 3.1.6 on centos, so that's what I used to config this system. This is what I've had to fix on my own so far (please correct me if I've done something wrong):

    First, I had to do a sa-update if I wanted to start amavisd succesfully. It seems rules were not available yet. Then amavisd started, but for some unknown reason these two entries were not created in amavisd.conf, related to dkim:
    notify_method => 'smtp:[]:10027',
    forward_method => 'smtp:[]:10025',

    I still have doubts if these are right... Could you please confirm? Port 10027 in /etc/postfix/ is the one with the -o milter_macro_daemon_name=ORIGINATING option, I understand that's for the notification_method, isn't it?

    Also, postgrey wasn't correctly configured, since it created a socket instead of opening a port. I had to modify /etc/sysconfig/postgrey accordingly.

    That is all for now.

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Always use the latest ISPConfig version, which is 3.1.10, 3.1.6 is quite old and later versions contain fixes for CentOS 7.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    When did you look into amavisd.conf? The amavisd.conf file on CentOS is completely replaced by ISPConfig during install, so don't look at any config files before you installed ISPConfig.

    The notify and forward method should be set to:

    $notify_method = 'smtp:*';
    $forward_method = 'smtp:*'; # set to undef with milter!

    as it is used in the ISPConfig amavisd.conf file.
  10. Ignacio Garcia

    Ignacio Garcia New Member

    Strange. first day logs were complaining about not communicating with port 10025. Today, after following your instructions and removing those two entries, it works. I'll keep a close eye on it...


    till likes this.

Share This Page