Incoming emails are rejected after update

Discussion in 'Installation/Configuration' started by minyor, Oct 19, 2020.

  1. minyor

    minyor New Member

    Hello I have similar problem as in this thread:
    https://www.howtoforge.com/community/threads/after-update-ubuntu-ubuntu-18-04-2.81908/

    Os: Debian 9
    ispconfig_update.sh generates '/etc/courier/authmysqlrc' without MYSQL_OPT and NAME: MARKER
    If I add these parameters manually then I can login in redcube but all incoming mails rejected with this error:
    warning: connect to private/quota-status: No such file or directory
    warning: problem talking to server private/quota-status: No such file or directory

    Can someone, please help me?
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    So you're using courier? Courier support will be dropped and is already removed as supported daemon from the website. So you will have to convert your setup to Dovecot.

    Which ISPConfig version do you have installed?
     
  3. minyor

    minyor New Member

    Hi, my ISPConfig Version is 3.2.
    Hm, I didn't know courier was deprecated, thanks for the info.
    I think I'll try to setup Dovecot instead..
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  5. minyor

    minyor New Member

    Yes, I should read release notes more often..
    I've installed dovecot and reconfigured ispconfig (I don't care for mail history though)
    Everything is working great, thank you again for being helpful
     
    Th0m and Jesse Norell like this.
  6. forbin42

    forbin42 New Member

    Not to nitpick but the release notes state "We are going to drop support for Courier in the future". Is it still supported because I just updated and 3.2.1 has broken all kinds of things including my mail server (which is still Courier). Is support definitely gone? My ISPConfig web interface is now broken and I can't even get in to reconfigure anything. I just get failed to open page althoiugh websites still seem to be working.

    For Postfix I am getting:
    Dec 1 15:20:57 c3p0 postfix/smtpd[15829]: NOQUEUE: reject: RCPT from mail141.suw161.rsgsv.net[198.2.175.141]: 451 4.3.5 <[email protected]>: Recipient address rejected: Server configuration problem;

    Dec 1 15:20:56 c3p0 postfix/smtpd[15829]: NOQUEUE: filter: RCPT from mail141.suw161.rsgsv.net[198.2.175.141]: <[email protected]et>: Sender address triggers FILTER lmtp:[127.0.0.1]:10026; from=<[email protected]et> to=<[email protected]> proto=ESMTP helo=<mail141.suw161.rsgsv.net>
     
  7. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Courier is supported in 3.2.1. Why can't you get into the panel? Did you reconfigure services? Are there any old conf-custom templates?
     
  8. forbin42

    forbin42 New Member

    I am also getting when i try to go to the web interface:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at [email protected] to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Any help would be appreciated
     
  9. forbin42

    forbin42 New Member

    Yes i did reconfigure services. And no there are no conf-custom templates I am aware of
     
  10. forbin42

    forbin42 New Member

    I am reviewing the changes to my main.cf and master.cf Postfix files and see a lot of changes made from the 3.2.1 update. (I updated from 3.1.8) There are a lot of new restrictions, addition of lmtp, removed my SPF recipient check parameter, etc so something is definitely conflicting
     
  11. forbin42

    forbin42 New Member

    So I have fixed a majority of the services from restoring the backup conf files. I can finally receive mail again. I am pretty much down to SASL not being able to receive and send mail and the web interface is just unresponsive. I am getting:
    Code:
    saslauthd.service - LSB: saslauthd startup script
       Loaded: loaded (/etc/init.d/saslauthd; generated; vendor preset: enabled)
       Active: active (running) since Tue 2020-12-01 16:22:00 EST; 6s ago
         Docs: man:systemd-sysv-generator(8)
      Process: 10715 ExecStop=/etc/init.d/saslauthd stop (code=exited, status=0/SUCCESS)
      Process: 10797 ExecStart=/etc/init.d/saslauthd start (code=exited, status=0/SUCCESS)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/saslauthd.service
               └─10820 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 0
    
    Dec 01 16:22:00 c3p0 systemd[1]: Starting LSB: saslauthd startup script...
    Dec 01 16:22:00 c3p0 saslauthd[10820]:                 : master pid is: 10820
    Dec 01 16:22:00 c3p0 saslauthd[10820]:                 : listening on socket: /var/spool/postfix/var/run/sas
    Dec 01 16:22:00 c3p0 saslauthd[10797]: Starting SASL Authentication Daemon: saslauthd.
    Dec 01 16:22:00 c3p0 systemd[1]: Started LSB: saslauthd startup script.
    Dec 01 16:22:02 c3p0 saslauthd[10844]: pam_mysql - SELECT returned no result.
    Dec 01 16:22:02 c3p0 saslauthd[10846]: pam_mysql - SELECT returned no result.
    Dec 01 16:22:07 c3p0 saslauthd[10848]: pam_mysql - SELECT returned no result.
     

Share This Page