inaccessible phpMyAdmin interface

Discussion in 'ISPConfig 3 Priority Support' started by peterMax, Aug 12, 2016.

  1. peterMax

    peterMax New Member

    Hello,
    I'm newbie on linux debian,
    After installation of ispconfig on a vps server via scribed to manage your apache web server: everything went well but impossible to enter phpmyadmin. link displays error 404.
    What can i do ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a Apache or Nginx web server?
     
    Last edited by a moderator: Aug 12, 2016
  3. peterMax

    peterMax New Member

    The web server is Apache
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run the command:

    dpkg-reconfigure phpmyadmin

    to configure PHPMyAdmin again and ensure that apache2 is selected as option. This can be a bit tricky when you are not familiar with the Debian apt system, you have to navigate to the option with the tab key, then select it by using the space bar on your keyboard.
     
  5. peterMax

    peterMax New Member

    I have this error message :
    [email protected]:/# dpkg-reconfigure phpmyadmin
    /usr/sbin/dpkg-reconfigure: phpmyadmin is broken or not fully installed
     
  6. peterMax

    peterMax New Member

    i tryed to restart mysql. I get this message :
    [email protected]:/# /etc/init.d/mysql restart
    [ ok ] Stopping MySQL database server: mysqld.
    [ ok ] Starting MySQL database server: mysqld ..
    [info] Checking for tables which need an upgrade, are corrupt or were not closed cleanly..
    [email protected]:/#
     
  7. peterMax

    peterMax New Member

    i tryed to intall phpmyadmin, the system break after just 5 seconds with this message:

    [email protected]:/# apt-get install phpmyadmin
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
    phpmyadmin
    0 upgraded, 1 newly installed, 0 to remove and 106 not upgraded.
    Need to get 5522 kB of archives.
    After this operation, 15.7 MB of additional disk space will be used.
    Get:1 http://security.debian.org/ wheezy/updates/main phpmyadmin all 4:3.4.11.1-2+de b7u5 [5522 kB]
    Fetched 5522 kB in 0s (10.0 MB/s)
    Preconfiguring packages ...
    Selecting previously unselected package phpmyadmin.
    (Reading database ... 41408 files and directories currently installed.)
    Unpacking phpmyadmin (from .../phpmyadmin_4%3a3.4.11.1-2+deb7u5_all.deb) ...
    Processing triggers for man-db ...
    Processing triggers for hicolor-icon-theme ...
    Setting up phpmyadmin (4:3.4.11.1-2+deb7u5) ...
    dbconfig-common: writing config to /etc/dbconfig-common/phpmyadmin.conf
    Replacing config file /etc/phpmyadmin/config-db.php with new version
    [....] Reloading web server config: apache2apache2: Could not reliably determine the server's fully qualified domain name, using 0.0.90.253 for ServerName
     
  8. peterMax

    peterMax New Member

    it makes me think of my hosts and hostname files. I had some doubt about the configuration of these two files. Besides, I wanted to change the name hostname (replace the numbers by a more comprehensible name come "MYSERVER1"), but each server reboot of the old name hostname, returned.
    My /etc/hosts:
    content exactly on the hosts file :
    127.0.0.1 localhost.localdomain localhost
    # Auto-generated hostname. Please do not remove this comment.
    98.24.109.199 23293.s.ovgo5.eu bogossemania 23293 bogossemania.localdomain
    ::1 localhost.localdomain localhost

    And My /etc/hostname :
    [email protected]:/# cat /etc/hostname
    23293

    # ---------
    what can i do for this situation ?
    Thank you for your help.
     
    Last edited: Aug 12, 2016
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    A number as hostname is not a good idea in my opinion, it might lead to problems that mail from your server gets flagged as spam later. I guess this is a vserver? In this case, take a look at the controlpanel of your ISP to see if you can set a custom hostname there.

    Regarding phpmyadmin, according to the output that you posted, the installation of phpmyadmin finished, the apache message is just a notice and not an error. Does phpmyadmin works now?
     

Share This Page