Impossible to access to phpmyadmin from the path /phpmyadmin

Discussion in 'Installation/Configuration' started by GuillaumeMdA, Sep 23, 2017.

  1. GuillaumeMdA

    GuillaumeMdA New Member

    Hello,

    so, I'm coming back as I didn't yet resolved my problem wiht phpmyadmin (which seems recurrent on ISPConfig 3): I'm not able to find andd access to the page of phpmyadmin through the path /phpmyadmin...
    If I click on the button of phpmyadmin in "Database" page of ISPConfig, it show a 404 page with "The requested URL /phpmyadmin was not found on this server".

    I tried many solutions as found on this forum but no one was working for me yet... (but many of them are quiet old or don't match with my distro, for example they say to modify phpmyadmin.conf (which doesn't exist for me) or /etc/apache2/conf.d/phpmyadmin.conf which doesn't exist too...).

    My config:
    - Debian 9.1.0
    - ISPConfig 3.6.1



    Hope to find some helps on this...

    Cheers
     
    Last edited: Sep 23, 2017
  2. HSorgYves

    HSorgYves Active Member

    Do you have phpMyAdmin installed?
     
  3. GuillaumeMdA

    GuillaumeMdA New Member

    Of course yes... I think... ;)
    When I ask apt-cache policy phpmyadmin, it returns:
    phpmyadmin:
    Installed: 4:4.6.6-4
    Candidate: 4:4.6.6-4
    Version table:
    *** 4:4.6.6-4 500
    500 http://deb.debian.org/debian stretch/main amd64 Packages
    100 /var/lib/dpkg/status
     
  4. HSorgYves

    HSorgYves Active Member

    Does /etc/phpmyadmin/apache.conf exist?
     
  5. GuillaumeMdA

    GuillaumeMdA New Member

  6. HSorgYves

    HSorgYves Active Member

    ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.conf
    service apache2 restart
     
  7. GuillaumeMdA

    GuillaumeMdA New Member

    Thanks, but it returns: ln: failed to create symbolic link '/etc/apache2/conf.d/phpmyadmin.conf': No such file or directory
    As I wrote before, I haven't such file (phpmyadmin.conf)... nor such directory (conf.d) in Apache2. I have only a conf.d directory in /etc/phpmyadmin/ (which is empty).
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    then try instead:

    ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-enabled/phpmyadmin.conf
    service apache2 restart
     
  9. GuillaumeMdA

    GuillaumeMdA New Member

    Yes, it's working!
    Thank you very much Till!
    And thank you too HSorgYves for your time to try to resolve my problem.

    ISPConfig 3 is the best open source panel! :)
     

Share This Page