Discussion in 'Server Operation' started by DantePasquale, May 31, 2009.

  1. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Hi Guys,

    I setup a laptop according to the howto, Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.10). My idea was to use imapsync to copy the imap datat from my server to the laptop and then install Ubuntu 9 and ISPConfig 3, then copy the imap data from the laptop to the server. Currently, my server is running Ubuntu 8.10 with ISPConfig 2.

    I downloaded and built imapsync per the instructions with imapsync. This is strange, but it would connect to the server without any problems, but wouldn't connect to the laptop.

    I'm pretty sure that the problem lies in the way the email address for the howto uses a full email address, eg [email protected]. I think imapsync doesn't deal with the @ sign. If I put the email in double quotes, it didn't matter. I tried to escape the @ with a \ backslash, but then the backslash got passed into the imap server and no match was found.

    I tried setting up the laptop with email address of 'someuser' without the, but that wouldn't work.

    To complicate things, I can connect to the laptops mail service with Thunderbird (using SSL) with [email protected] as the connect string!

    I guess the question is, since imapsync is perl, how can I pass in the so that it gets passed to the imap server correctly??

    Thanks, Danté
    Last edited: Jun 1, 2009

Share This Page